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Preface

Copyright Notice

Copyright ©2020

Nanjing DECOWELL Automation Co., Ltd.Copyright, all rights reserved. Without the written
permission of our company, no unit or individual may excerpt or copy part or all of the

contents of this document without authorization, and may not disseminate it in any form.

1 I T 319 Wy ||

MELWU Y ELL WELLLINKIO are trademarks of our company. Other

registered trademarks appearing in this document are owned by their respective owners.
Due to product version upgrades or other reasons, the contents of this document are subject
to periodic updates. Unless otherwise agreed, this document is for reference only, and all
statements, information, and recommendations contained herein do not constitute any
express or implied warranty.

Scope of this document

This document is applicable to FS Series Remote 10 system

Introduction

This manual mainly introduces FS technical specifications, installation, and commissioning
of the series of remote I/O modules. The main contents include:

® System Overview: Provides an introduction to the FS Series remote 1/0 modules,
including ordering information, product composition, system architecture, as well as
transportation and storage environment.

® Product Description: Details the technical specifications of the FS Series remote 1/0O
modules.

® |nstallation and Removal Guide: Describes how to install and remove the FS Series
remote I/O modules.

® Mechanical and Electrical Drawings: Includes dimensional drawings and electrical wiring
diagrams of the FS Series remote 1/0O modules.

® User Guide: Demonstrates how the FS Series remote I/O modules communicate and

connect with various mainstream PLCs through practical examples.

Precautions
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This document describes in detail the WELL-LINK FS usage of the series remote 1/O
modules is for people with certain engineering experience. Nanjing DECOWELL is not
responsible for any consequences caused by the use of this information.

Before attempting to use the device, please read the relevant precautions of the device
carefully and be sure to comply with the installation and commissioning safety precautions
and operating procedures. For the possible hazards and damages caused by incorrect use

of the device, please refer to the following symbols.

A Warn

This mark indicates

"Dangers caused by failure to follow the instructions may result in personal

A Notice

This mark indicates

"Dangers caused by failure to follow the instructions may result in minor or]

@) Tips

This mark indicates

“Make necessary supplements or explanations to the description of the

Target customers

This manual provides information about FS Installation and commissioning information for a
range of remote 1/O modules, designed for engineers, installers, maintenance personnel and
electricians with general automation knowledge.

Recycling and Disposal

To ensure environmentally friendly recycling and disposal of your old device, please contact
a certified electronic waste disposal service.

Online Support

In addition to this manual, you can also obtain more product information by checking the
official website.

http://www.decowellauto.com
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1.System Overview
1.1 What is Remote 10

Remote 1/O, also known as distributed I/O, refers to electronic devices commonly used in
process or factory automation that transmit and receive input and output signals to and from
main electronic equipment (such as DCS, PLC, or PC) via communication technologies like

industrial fieldbus.

1.2 Composition

The FS Series remote I/O modules mainly consist of system status indicators, system power
supply, input/output channels, communication interface, and I/O channel indicators, as

shown in Figure 1-2.

[T
(1} Status light

TG HRETES (@ Bus communication interface

1
[

WELLLINKID

(3 System power input port
dbhda ke hdadbbak
(2} '»\ gERRERTY PRI PEYY L3
@) 170 port
: 5 1/0 Signal light

&) 1/0 port

Figure 1-2 FS Series Remote 10 Module composition

1.3 Features of the module

The FS Series remote I/O modules feature an integrated design that combines the
communication interface, input/output 1/O interfaces, system and I/O indicators. They are
characterized by high integration, rich communication protocols, compact size, and ease of

use.

1.4 Application areas

The FS Series remote I/0 modules are widely used across various fields, such as new
energy, lithium battery, non-standard automation, robotics, CNC machines, intelligent
parking systems, logistics sorting, educational equipment, environmental protection, and

heating systems.
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2.Module parameters

2.1 Naming conventions

PN-8800-CONN

* EC:EtherCAT Bus ‘

* PM:PROFINET Bus L pesere

* DN: DeviceNet Bus

« CLACC-Link Bus

TGN M Types of Digital output:
ElEtheret/ I Bus « D:Lowelectrical level output{NEHN)

« Ei2: EtherNet/IP Bus ) 1: High electrical level output [ PNE)

. CA: CANopenBus » 2: Relay

Digital Input Paint

* B:R-channels dighal cotput Types of Blgitsl Input
H: 16-channels digitat cutput * (nEffactive low sectrical level output{NPN)
» 5:32-channetsdigital outpue 1: Effective high electrical level (PNP)

* [ Compatible (NPHNEPNP)

Digital Output Point
* §:8-channels digial cutput

Recerve
H 16-channels digital ootput

* 5:32-channeisdigital outpue

2.2 Module communication protocol interface parameters

It mainly introduces parameters such as bus protocol, interface type, interface mode and

communication rate in the module.
2.2.1 PROFINET protocol

PROFINETModule Communication Protocol Interface Parameters

Bus protocol PROFINET
Interface Type Industry EtherNET
Interface 2xRJ45
Communication rate 100Mbps
Communication distance 100m (distance between stations)
Electrical isolation have

PN Module system indicator light description

Indicator :
1 lllustrate Color State Meaning
Lights
Power ON Power supply is normal
1 | POWER . -
indicator green OFF The power supply is disconnected or faulty.
5 RUN | Bunning green ON |Equipment running and the communicati.on is normal
indicator light OFF No power or system abnormality
3 SF --- - - -
System fault ON Communication abnormality
4 BF - red 5 . .
indicator OFF |Equipment running and the communication is normal
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PN2 Module system indicator light description

Indicator . .
. illustrate color meaning
Lights
1 POWER . Pc')wer green ON Power Sl.Jpp!y is normal
indicator OFF The power supply is disconnected or faulty.
Running ON The eqmpme.nt |§ runnlng and the
2 RUN indicator liaht green communication is normal
g OFF No power or system abnormality
3 SF - --- - -
ON Communication abnormality
4 BF System fault red The equipment is running and the
indicator OFF quip o u. 9
communication is normal
Flash 5HZ Flashing during the upgrade process
Maintenance Flash 1HZ | Flashes when the reset button is pressed
5 MT . green .
indicator ON Reset operation completed
OFF Non-maintenance status

2.2.2 EtherCAT protocol

EtherCATModule communication protocol interface parameters

Bus protocol EtherCAT
Interface Type Industry EtherNET
Interface 2xRJ45
Communication rate 100Mbps
Communication distance 100m (distance between stations)
Electrical isolation have

EtherCAT Module system indicator light description

NO. Indicator Lights illustrate color state meaning
ON Power supply is normal
1 POWER Power indicator| green OFF The power supply is disconnected or
faulty.
ON OP Status, running normally
OFF INIT Status, initialization status
5 RUN . Running green Flash PRE?O.I.D §tatgs, communication
indicator light initialization completed
. SAFE-OP Status, SDO and PDO
Single flash .
Unavailable
ON Application controller failure
OFF No Error
System fault . Process data watchdo
3 ERR }i/ndicator red Flashes twice timeout/EtherCAT watchdog ?imeout
Flash once Local Error
Flash Configuration Error
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2.2.3 CC-Link protocol
® CC-Link module communication protocol interface parameters

CC-Link module communication protocol interface parameters

Bus protocol CC-Link
Working Mode CC-Link remote I/O station
Connection Shielded twisted pair
Communication rate 156kbps~10Mbps
Address Configuration 1~64
Electrical isolation have

® CC-Link remote 10 Module DIP Setting

CCLink communication rate setting

A I Communication Baud Dial position =~ Communicatio Corresponding
5/ « Rate Setting number n rate transmission distance
« Station Number Setting x10 (1) ;ggiigz 1620000|»]r:l
2 2.5Mbps 200m
« Station Number Setting x1 3 5Mbps 150m
4 10Mbps 100m

CC Link module system indicator light description

NO. Indicator Lights illustrate color meaning
ON Power supply is normal
1 POWER |Power indicator green The power supply is
OFF .
disconnected or faulty.
Running ON The equipme.nt i§ rurming and
2 RUN indicator liaht green the communication is normal
g OFF Connection not established
ON Module communication
3 ERR System fault red abnormality
indicator Module communication is
OFF
normal

2.2.4 DeviceNet protocol
® DeviceNet module communication protocol interface parameters

DeviceNet Module communication protocol interface parameters

Bus protocol DeviceNet
Connection Shielded twisted pair
Communication rate 125kbps/250kbps/500kbps
Address Configuration 0~63
Electrical isolation have

10
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DeviceNet communication interface Position No.  Signal Signal Definition
1 V+ Positive power supply
2 CH Data signal positive
3 SLD Shielded wire
4 CL Data signal negative
5 V- Negative pole of power supply

® DeviceNet Remote IO Module communication interface definition

g Communication Baud DeviceNet communication rate setting
~fffm Rate Setting
b

0 125kbps
‘ * Station Number Setting x10 1 2 50kbp S

: 2 500kb
“' ]| < s1ation Number Setting x1 pS

color state meaning
ON Power supply is normal
1 POWER | Power indicator| green OFF The power supply is disconnected or
faulty.
Running ON The eqmpme.nt |§ rurmlng and the
2 RUN indicator liaht green communication is normal
g OFF Connection not established
3 ERR System fault red ON Module communication abnormality
indicator OFF Module communication is normal

2.2.5 CC-LinkIE FieldBASIC Protocol

CC-Link IE Field BasicModule communication protocol interface parameters

Bus protocol CC-Link IE Field Basic
Interface Type Industry EtherNET
Interface 2xRJ45
Communication rate 100Mbps
Communication distance 100m (distance between stations)
Electrical isolation have

CC-Link IE Field BASIC module system indicator light description

1
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NO. Indicator Lights illustrate color state meaning
. ON Power supply is normal
1 POWER Power indicator | green OFF |The power supply is disconnected or faulty.
ON The equipment is running and the
5 RUN Running green communication is normal
indicator light OFF Connection not established
Flash Factory reset signal detected
3 ERR System fault red ON Module communication abnormality
indicator OFF Module communication is normal

2.2.6 CANopen protocol
® CANopen module communication protocol interface parameters

CANopen module communication protocol interface parameters

Bus protocol CANopen
Connection Shielded twisted pair
Communication rate 10kbps~1Mbps
Address Settings DIP switch settings

The maximum communication distance is determined by the
communication rate

Communication distance

Electrical isolation have
CANopen communication interface Position No. Signal Signal Definition
1 +V Positive power supply
§ ) 2 CH Data signal positive
—t 3 SLD Shielded wire
= 4 CL Data signal negative
5 -V Negative pole of power supply

® CANopen remote 10 Module communication interface definition

® CANopen remote |10 Module DIP Setting

{ CANOpen communication rate setting

10kbps

20kbps

50kbps
100kbps
125kbps
250kbps
500kbps
1000kbps

Communication Baud

Rate Setting

Station Number Setting x10

t 1

Station Number Setting x1

N[O~ WIN|~|O

CC-LinkIE FieldBASIC module system indicator light description

12
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NO. Indicator Lights illustrate color meaning
Power ON Power supply is normal
1 POWER indicator green OFF The power supply is disconnected or
faulty.
ON The module enters the operating state and
the communication is normal.
Running OFF The module enters the initialization state
2 RUN - ) green
indicator light 1 flash ,
The module enters the operation stop state
long off
5HZ Flash | The module enters pre-operationstate;
3 ERR S)l/st(?m fault red ON Module failure .
indicator OFF The module enters the running state

2.2.7 EtherNet/IP protocol

EtherNet/IP Module communication protocol interface parameters

Bus protocol EtherNet/IP
Interface Type Industry EtherNET
Interface 2xRJ45
Communication rate 100Mbps
Communication distance 100m (distance between stations)
Electrical isolation have

EtherNet/IPModule system indicator light description

Indicator
Lights

illustrate meaning

ON Power supply is normal
OFF The power supply is disconnected or faulty.

1 | POWER |Power indicator| green

ON Th i ti ti I
green e equipment is operating normally
1HZFlash Standby, device not configured yet
Red and | 1HZFlash Self-test, the device is performing a
Module status power-on test
2 MS . Green X
indicator OFF The device has no power
ON Main faults: The device has detected a
major, unrecoverable fault.
red No power supply:The device is missin
1HZFlash P PRYY: 9
power.
Connected, the device has at least one
ON ) .
established connection
green No connection, the device has not
Network status 1HZFlash o .
3 NS S established a connection
indicator

Self-test, the device is performing a
power-on test
OFF No power or no IP address

Red and | 1HZFlash
Green

13
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ON Repeat IP address

red Connection timed out. One or more
1HZFlash , . ) .
connections to this device have timed out.

Flash 5HZ Flashing during the upgrade process

Maintenance Flash 1HZ | Flashes when the reset button is pressed
4 MT . green .
indicator ON Reset operation completed
OFF Non-maintenance status

2.3 Module input/output channel technical parameters
2.3.1 XX-8800-CONN
Tip: XX represents the bus protocol to be selected (for example:PN_ EC, CL, Cl, CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

® XX-8800-CONN Integrated module model

model Specifications
XX-8800-CONN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)
XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)
XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)
XX-HHOO0-CONN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)
XX-HHOO0-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)
XX-S000-CNNN 32 digital inputs (NPN & PNP)
XX-0S00-NONN 32 digital outputs (NPN)
XX-0S00-N1NN 32 digital outputs (PNP)

® Module parameter introduction

Technical Parameters

model XX-8800-CONN
Product Name 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)
Rated input voltage 24V(18~36V)
Current consumption 38mA
Number of input channels 8
Input signal type NPN&PNP compatible (Transistor)
NPN Signal Level 0~5V
PNP Signal Level 15~30V
Current ((::cr)]r;snurl]rglption per 5mA
Port protection Overvoltage protection
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Electrical isolation

Output channel parameters

AC500V

Number of output 8
channels
Input signal type NPN(transistor)

Rated level 0V(Max: 1.5V)
Single gzﬁgﬂfl rated Max: 0.5A (8The total current output by the channels is 2A)

Port protection

Overvoltage and overcurrent protection

Electrical isolation

AC500V

Physical parameters

Dimensions 90mmx100mmx45.4mm
Operating temperature -10~55C
Storage temperature -25~85C
Relative humidity 95% non-condensing
Protection level P20

2.3.2 XX-8800-C1NN

Tip: XX represents the bus protocol to be selected (for example:PN. EC, CL, CI, CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

® XX-8800-C1NNIntegrated module model

model

Specifications

XX-8800-CONN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)

XX-8800-C1NN

8-channel digital input (NPN & PNP) 8-channel digital output (PNP)

XX-8800-C2NN

8-channel digital input (NPN & PNP) 8-channel digital output (relay)

XX-HHOO-CONN

16-channel digital input (NPN & PNP) 16-channel digital output (NPN)

XX-HHOO-C1NN

16-channel digital input (NPN & PNP) 16-channel digital output (PNP)

XX-S000-CNNN

32 digital inputs (NPN & PNP)

XX-0S00-NONN

32 digital outputs (NPN)

XX-0S00-N1NN

32 digital outputs (PNP)

® Module parameter introduction

Technical Parameters

model

XX-8800-C1NN

Product Name

8-channel digital input (NPN & PNP) 8-channel digital output (PNP)

Bus protocol

PROFINET,EtherCAT,CC-Link,DeviceNet
CC-LinkIE Field Basic, CANopen

Rated input voltage

24V/(18~36V)

Current consumption

38mA

15
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Input channel parameters
8

Number of input

channels

Input signal type NPN&PNP Compatible (Transistor)
NPN signal Level 0~5V

PNP signal Level 15~30V

Current consumption 5mA
per channel

Port protection Overvoltage protection

Electrical isolation AC500V

Output channel parameters

Number of output

8
channels
Input signal type PNP(transistor)
Rated level 24\/(18~36V)
Single 2322:? rated Max: 0.5A (8The total current output by the channels is 2A)
Port protection Overvoltage and overcurrent protection
Electrical isolation AC500V
Physical parameters
Dimensions 90mmx100mmx45.4mm
Operating temperature -10~55C
Storage temperature -25~85C
Relative humidity 95% non-condensing
Protection level IP20

2.3.3 XX-8800-C2NN
Tip: XX represents the bus protocol to be selected (for example:PN. EC, CL, Cl, CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

® XX-8800-C2NNIntegrated module model

model Specifications
XX-8800-CONN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)
XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)
XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)
XX-HHOO0-CONN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)
XX-HHOO0-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)
XX-S000-CNNN 32 digital inputs (NPN & PNP)
XX-0S00-NONN 32 digital outputs (NPN)
XX-0S00-N1NN 32 digital outputs (PNP)

16
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® Module parameter introduction

Technical Parameters

model XX-8800-C2NN
Product Name 8-channel digital input (NPN & PNP) 8-channel digital output (relay)
Bus protocol PROFINE_T,EtherCAT,C(_)-Link,DeviceNet
CC-LinkIE Field Basic, CANopen
Rated input voltage 24\/(18~36V)
Current consumption 38mA

Input channel parameters

Number of input 8
channels

Input signal type NPN&PNPCompatible (Transistor)
NPNSignal Level 0~5V

PNPSignal Level 15~30V

Current consumption 5mA
per channel

Port protection Overvoltage protection

Electrical isolation AC500V

Output channel parameters

Number of output 8
channels
Input signal type Relay (normally open)
Rated level 240VAC/30vDC
Single channel rated 5A
current
Port protection Overvoltage and overcurrent protection

Electrical isolation AC500V

Physical parameters

Dimensions 90mmx100mmx45.4mm
Operating temperature -10~55°C
Storage temperature -25~85C
Relative humidity 95% non-condensing
Protection level IP20

2.3.4 XX-HH00-CONN
Tip: XX represents the bus protocol to be selected (for example:PN, EC, CL,Cl,CAetc.), the

input and output parameters and external dimensions of the modules are consistent.
® XX-HHOO0-CONNIntegrated module model

Specifications

XX-8800-CONN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)

17
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XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)
XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)
XX-HHOO0-CONN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)
XX-HHOO0-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)
XX-S000-CNNN 32 digital inputs (NPN & PNP)

XX-0S00-NONN 32 digital outputs (NPN)

XX-0S00-N1NN 32 digital outputs (PNP)

® Module parameter introduction

Technical Parameters

model XX-HHOO0-CONN
Product Name 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)
Bus protocol PROFINE_T,EtherCAT,C(;-Link,DeviceNet
CC-LinkIE Field Basic, CANopen
Rated input voltage 24\/(18~36V)
Current consumption 40mA

Input channel parameters

Number of input
16
channels
Input signal type NPN&PNPCompatible (Transistor)
NPN Signal Level 0~5%Vv
PNP Signal Level 15~30V
Current consumption 5mA
per channel
Port protection Overvoltage protection
Electrical isolation AC500V
Output channel parameters
Number of output
16
channels
Input signal type NPN(transistor)
Rated level 0V(Max: 1.5V)
Single ggfrg:ffl rated Max: 0.5A (8The total current output by the channels is 2A)
Port protection Overvoltage and overcurrent protection
Electrical isolation AC500V

Physical parameters

Dimensions 90mmx100mmx45.4mm
Operating temperature -10~55C
Storage temperature -25~85C
Relative humidity 95% non-condensing

18
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Protection level

IP20

2.3.5 XX-HH00-C1NN

Tip: XX represents the bus protocol to be selected (for example:PN. EC, CL,Cl,CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

® XX-HHO0O0-C1NNIntegrated module model

model

Specifications

XX-8800-CONN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)
XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)
XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)

XX-HHOO-CONN
XX-HHOO-C1NN
XX-S000-CNNN

16-channel digital input (NPN & PNP) 16-channel digital output (NPN)
16-channel digital input (NPN & PNP) 16-channel digital output (PNP)
32 digital inputs (NPN & PNP)

XX-0S00-NONN

32 digital outputs (NPN)

XX-0S00-N1NN

32 digital outputs (PNP)

® Module parameter introduction

Technical Parameters

model

XX-HHOO-C1NN

Product Name

16-channel digital input (NPN & PNP) 16-channel digital output (PNP)

Bus protocol

PROFINET,EtherCAT,CC-Link,DeviceNet
CC-LinkIE Field Basic, CANopen

Rated input voltage

24V/(18~36V)

Current consumption

Number of input
channels

40mA

Input channel parameters

16

Input signal type

NPN&PNPCompatible (Transistor)

per channel

NPNSignal Level 0~5%Vv
PNPSignal Level 15~30V
Current consumption 5mA

Port protection

Overvoltage protection

Electrical isolation

Number of output
channels

AC500V

Output channel parameters

16

Input signal type

PNP(transistor)

Rated level

24V(18~36V)

Single channel rated

Max: 0.5A (8The total current output by the channels is 2A)
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current
Port protection Overvoltage and overcurrent protection
Electrical isolation AC500V

Physical parameters

Dimensions 90mmx100mmx45.4mm
Operating temperature -10~55C
Storage temperature -25~85C
Relative humidity 95% non-condensing
Protection level 1P20

2.3.6 XX-S000-CNNN
Tip: XX represents the bus protocol to be selected (for example:PN. EC, CL,CI,CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

® XX-S000-CNNNIntegrated module model

XX-8800-CONN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)
XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)
XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)
XX-HHOO0-CONN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)
XX-HHOO0-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)
XX-0S00-NONN 32 digital outputs (NPN)

XX-0S00-N1NN 32 digital outputs (PNP)

® Module parameter introduction

Technical Parameters
model XX-HHOO-CONN

Product Name 32 digital inputs (NPN & PNP)

PROFINET,EtherCAT,CC-Link,DeviceNet
CC-LinkIE Field Basic, CANopen

Rated input voltage 24\/(18~36V)
Current consumption 40mA

Bus protocol

Input channel parameters

Number of input

channels 32
Input signal type NPN&PNPCompatible (Transistor)
NPNSignal Level 0~5%Vv
PNPSignal Level 15~30V
Current consumption 5mA
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per channel
Port protection Overvoltage protection
Electrical isolation AC500V

Physical parameters

Dimensions 90mmx100mmx45.4mm
Operating temperature -10~55C
Storage temperature -25~85C
Relative humidity 95% non-condensing
Protection level 1P20

2.3.7 XX-0S00-NONN
Tip: XX represents the bus protocol to be selected (for example:PN. EC, CL,CI,CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

® XX-0S00-NONNIntegrated module model

XX-8800-CONN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)
XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)
XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)
XX-HHOO0-CONN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)
XX-HHOO0-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)
XX-S000-CNNN 32 digital inputs (NPN & PNP)

XX-0S00-NONN 32 digital outputs (NPN)

XX-0S00-N1NN 32 digital outputs (PNP)

® Module parameter introduction

Technical Parameters
model XX-0S00-NONN

Product Name 32 digital outputs (NPN)

PROFINET,EtherCAT,CC-Link,DeviceNet
CC-LinkIE Field Basic, CANopen

Rated input voltage 24\/(18~36V)
Current consumption 40mA

Bus protocol

Output channel parameters

Number of output
32
channels
Input signal type NPN(transistor)
Rated level 0V(Max: 1.5V)
Single gl:]frgfl rated Max: 0.5A (8The total current output by the channels is 2A)
Port protection Overvoltage and overcurrent protection
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Electrical isolation AC500V
Dimensions 90mmx100mmx45.4mm
Operating temperature -10~55C
Storage temperature -25~85C
Relative humidity 95% non-condensing
Protection level IP20

2.3.8 XX-0S00-N1NN

Tip: XX represents the bus protocol to be selected (for example:PN, EC, CL,Cl,CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

® XX-HHOO0-C1NNIntegrated module model

model

Specifications

XX-8800-CONN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)
XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)
XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)

XX-HHOO-CONN

16-channel digital input (NPN & PNP) 16-channel digital output (NPN)

XX-HHOO-C1NN

16-channel digital input (NPN & PNP) 16-channel digital output (PNP)

XX-S000-CNNN

32 digital inputs (NPN & PNP)

XX-0S00-NONN
XX-0S00-N1NN

32 digital outputs (NPN)

32 digital outputs (PNP)

® Module parameter introduction

Technical Parameters

model

XX-0S00-N1NN

Product Name

32 digital outputs (PNP)

Bus protocol

PROFINET,EtherCAT,CC-Link,DeviceNet
CC-LinkIE Field Basic, CANopen

Rated input voltage

24V(18~36V)

Current consumption

Number of output
channels

40mA

Output channel parameters

32

Input signal type

PNP(transistor)

Rated level 24\/(18~36V)
Single 2322:? rated Max: 0.5A (8The total current output by the channels is 2A)

Port protection

Overvoltage and overcurrent protection

Electrical isolation

AC500V
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Dimensions 90mmx100mmx45.4mm
Operating temperature -10~55°C
Storage temperature -25~85C
Relative humidity 95% non-condensing
Protection level IP20
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3.Module Installation

3.1 Basics

FS protection level of the series modules is IP20, which means that FSThe series
modules can only be installed on rails, control cabinets or electrical operating rooms and in
dry environments (protection levellP20). Safety protection must be provided in cabinets,
control cabinets or operating rooms to prevent electric shock and fire spread.

FS series modules can be mounted on mounting rails in accordance with EN 60715
(35%7.5 mm or 35%x15 mm). In the control cabinet, separate grounding of the mounting rail is
required. Exception: If the rail is mounted on a grounded galvanized mounting plate,

separate grounding of the rail is not required.

3.2 Installation clearance

When installing and removing FS series modules, a minimum clearance must be maintained,

as shown in Figure 3-1.

oo e oo

Figure 3-1Minimum installation clearance

3.3 10 Module installation and removal

3.3.1 10 Module Installation
1. First, pull out the rail clip under the module with a flat-blade screwdriver;

2. Hang the module on DIN350n the rail, use a flat-blade screwdriver to push the rail clip at

the bottom into place and lock it, as shown in Figure 3-2 shown.
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Figure 3-2 Module Installation
3.3.2 10 Module removal
1. First, pull out the rail clip under the module with a flat-blade screwdriver;

2. Gently pull the module out andIN35The guide rail forms an angle, and then pushes the

module out of the net, as shown in Figure 3-3shown.

Figure 3-3Module removal
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4.Dimensions and Wiring Diagram

4.1 Module Dimensions

FS dimensions of all modules in the series are consistent, that is, the length, width and

height are equal.

~

O o ooao

— 00000000 OoDooooooo
= ﬂ@iﬁ OoDooO0oO0OD0O0 oooooooo
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i
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Figure 4-1Module Dimensions

4.2Module power wiring diagram

The power wiring diagram for EtherCAT, PROFINET, CC-Link, and CC-Link IE Field

Basic remote I/0O modules in the FS series is shown in Figure 4-3.

A 4 =
24V OV PE

Figure 4-3Power wiring diagram

The wiring diagram of the DeviceNet remote 1/0O module in the FS series differs from that
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of modules using other bus protocols, as shown in Figure 4-4.

o|lo|o|Jo|Oo]O]|]C]O|O]|O
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Figure 4-4Power wiring diagram

4.3 Digital input channel wiring diagram

In the FS series remote 1/O modules, all input channels support both NPN and PNP

signal types; however, only one type—either NPN or PNP—can be used during operation.
4.3.1Digital input channel NPN Signal wiring diagram

24V -

(Y -
I

o olo o
|uo||:|°

Figure 4-5Digital input channels NPN connection

|I:I Oll:l o
|ﬂ Dll] (o]
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4.3.1Digital input channel PNP Signal wiring diagram
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Figure 4-5Digital input channels PNP connection

4.4 Digital output wiring diagram
4.4 1Digital output NPN Wiring Diagram

o[oJo[oJoJoJo[o[o[o
EEMREAEEEREE
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EEEEEEEE“;
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Figure 4-6Digital output channels NPN connection
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4.4.2Digital output PNP Wiring Diagram
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Figure 4-6Digital output channels PNP connection

4.5 Relay output wiring diagram
4.5.1 Relay output DC load wiring diagram
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Figure 4-7 Relay output DC load wiring diagram
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4.5.2 Relay output AC load wiring diagram
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Figure 4-8 Relay output AC load wiring diagram
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5.FS Series 10 configuration

This chapter mainly introduces the connection and configuration of FS series remote 1/0O

modules with mainstream industrial PLC, including configuration in the programming

software and parameter settings of certain modules.

5.1 EtherCAT Protocol

5.1.1 TwinCAT3andEtherCATProtocol IO Module connections and configuration
1. Communication connection diagram, as shown in Figure 5-1-1shown.

PC
TwinCAT3

EthercAT—

EC-8800-CONN

Figure 5-1-1Communication connection diagram
2. Hardware configuration as shown in Table 5-1-2Shown

Table 5-1-2Hardware Configuration Table

Hardware Quantity Remark
Programming Computer 1 InstallTwinCAT3
EC-8800-CONN 1 EtherCAT protocol 8DI/8DOModules
Network cable several

3, Install XML Description File
Installing XML description files into TwinCAT3As shown in Figure 5-1-3The default folder
for this example is (C:\TwinCAT\3.1\Config\lo\EtherCAT)

LR ]

» TwinCAT » 31 » Config > lo » EtherCAT » -

=4 tes B =0

[ Ex-1100 v1.5.4
|=| DECOWELL-FS_ V3.0.2
=] DECOWELL-FS_NoBITARR_V2.1.2
|%] DECOWELL-FS1_NoBITARR V2.1.2
Beckhoff Eldc

Beckhoff EPZwoe

Beckhol EP T

khott AT2woo

&) [ie] [

=] Becl

=] Beckhoff ELMSoo
=] Beckhoff EXM 1w
|£] Beckhoff ELIM 360
| %] Backhoff EL700
=] Bed|
|=| Bec
|Z] Bel

knoff EL250c

khoff B2
khoff EPdwax

WML =4

L ST

Figure 5-1-3Install XML Description File
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4. New project and equipment configuration
Open TwinCAT3In the software, select "File" > New > Project from the menu bar, as
shown in Figure 5-1-4As shown, in the New Project window, select "TwinCATprojects”, as

shown in Figure 5-1-5shown.

Lﬁ Starl Page - TcXaeShell (Administrator)

File '_ Edit  View Project Debug TwinCAT TwinSAFE PLC Team Scope Toc
[ New | v -1‘ Project... I CtrlsShiftsN |
File...

crrl+N

Open LR &

B Ctarf Dana
Figure 5-1-4New Project
B Recent Sort by: | Default - | 8 i=] arch [CLA4EL P -

TwirCAT Projects. . Types TwinCAT Projects
TwinCAT XAE Systern Mansger
Configuration

Nat Fnding what yo
Open i

Mame: TWINCAT Proget?
Lo<ation C\Usersiaingao I Documents Tckaesnal| - Bromse...
Soktion nae TwinCAT Progect2 | Create directory for sclietion
|_| Add to Source Cantral
i oK || cancel

Figure 5-1-5Select TwinCATproject
| connected to the programming computerOScan to the project, click
"/0O">Devices”>"Scan”, as shown in Figure 5-1-6As shown, the scanned hardware

configuration is shown in Figure 5-1-7shown.

3 solution TwinCAT Project2' (1 project) 4 @ I.I"ICI
4 TwinCAT Praoject2 '
:ﬁﬁi svs.TEMﬂjlecr 4 i}% Devices
%\_ MOTION 4 == Device 1 (EtherCAT)
3 ric
il SAFETY 5T Image
gc"* *® image-Infa
& vision 3
& anavvTics b 2 SyncUnits
4 Fio I Inputs
20 M O Add New item... Ine o Outputs
‘0 Add Bdsting ltem... sh [ m InfoData
Rename . . -
Add New Folder... 4 r! D ECAR LAY 2
Export EAZ Config File P Di
\ Scan P ‘ Do
Paste €t b B WcState
el il b [ InfoData
Figure 5-1-6 Scan 10 device Figure 5-1-7 Hardware Configuration
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5.1.2 CODESYS and EtherCAT Protocol I0 Module connections and configuration
1. Communication connection diagram, as shown in Figure 5-1-8shown.

PC
Codesys V3.5

EthercAT—

EC-8800-CONN

Figure 5-1-8Communication connection diagram
2. Hardware configuration as shown in Table 5-1-2Shown

Table 5-1-2Hardware Configuration Table

hardware quantity Remark
Programming Computer 1 InstallCodesysV3.5
EC-8800-CONN 1 EtherCAT protocol 8DI/8DOModules
Network cable several

3. Install XML Description File
Open CODESYS V3.5In the software, select "Tools" > "Device Repository" from the

menu bar, as shown in Figure 5-1-9shown.

| | Tools | Window Help

=¥ Device Repository *
@& CODESYS Installer...
tl Library Repository... Location | System Repository w Edit Locations...
v |.|j Device Repository.. | (C:\ProgramData\CODESYS\Devices)
&) Visual Element Repository .

& Visualization Style Repository... Installed Deyice Descriptions

W Ucense Repository.. String for a full text sear Vendor | <all vendors> v Install...
OPC UA Information Model Repository...

W Ucense Manager... MName Vendor Version Description
Device License Reader... + I_3 Miscelaneous
Customize.., + [ Fieldbuses
Options.. + Bl i1 devices
Import and Export Options.. + |_j PLCs
Seripting y + @ softMotion drives
Edge Gateway v
Miscellanecus 3

Figure 5-1-OInstall XML Device Description File
4. New project and equipment configuration
Open CODESYS V3.5Software, select New Project > Project > Standard project”, as

shown in Figure 5-1-10shown.
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2] New Project =

2] New Project... Lategoriss Iemplates

& Upen Project... il Libraries
[ | Projects .i
| Empty project  HMI prai Standard

(@ open Project from PLC...

Recent projects

@ Untitled2
@ Untitled1
& Faas
@ F@wHs
& Faas
@ Famsl
& Fake A project contaning ane device, one application, and an empty implemantation for PLC_PRG |

= &8l :
S Famy Name Untitied3 |

Location  |Ci\Users'sangtao hu'Desktop pficodesys v
[ Close page afterproject lozd

[ Show page on startup

| e

Messages - Total 0 ermr{s) 0 waming(s), 0 mess
Figure 5-1-10New Construction
In the standard project window, select "CODESYS SoftMotionWinV3”,PLC_PRGSelect

"Structured Text (ST)”, as shown in Figure 5-1-11shown.

Standard Project >

You are about to create a new standard project. This wizard will create the following
-_'i I objects within this project:
- One programmable device as specdified below
- & program PLC_PRG in the language specified below

- A cyclic task which calls PLC_PRG
- A reference to the newest version of the Standard library currently installed.

Device CODESYS SoftMotion Win V3 x64 (35 - Smart Software Solutions GmbH)

PLC_PRG in | Structured Text (ST) ~

Figure 5-1-11Select device and programming language
Tip: Softmotion can drive and 1/0, Control can only take /OBut not with drive.
In the device tree, "Device (CODESYS SoftMotionWinV3)">"Add device”, as shown in
Figure 5-1-12As shown, in the Add Device window, select Fieldbus > EtherCAT">EtherCAT

Master”, as shown in Figure 5-1-13 shown.
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§ Untiteds
: EB!DE\&C:(C(IE e
= B pLc Logic
-0 Aot 2 CoPY
.ﬁ b i Paste
.I.'ﬂ PL % Delete
= (@ 13 Refactoring »

B @ Properties...

% softvotion| i Add Object ,
) Add Folder...
Add Device...
Update Device...
7" Edit Object

Figure 5-1-12Add a device

1 Add Usvice

Name |EtherCAT Master

Action
(® Append device | Inset cevice 1g device () Update device
[Sl.nnu for 2 full text search Vendor | <all vendors>
MName Vendor Version Description
+ [ Miscelaneous
b ﬂ Fieldbuses
+ €A% CANbuS
= pol EtherCAT
= naf Master
[ oo intemal EtherCAT Master 35 - Smart Software Solutions GmbH ~ 4.4.0.0 Coono: imternal EtherCAT Master. .,
{1 [EthercAT Master 35 - Smart Soft s GrbH 4400  EtherCAT Master...
1] Ethercat Master SofiMation 35 - Smart Software Solutons GmbH  4.4.0.0  EtherCAT Master SoftMation...
+ WP Ethemnet Adapter
+ - EtherNet/IP
+ - {a} HomegBuilding Automation
+ I Modbus )
FA Group by category  [_] Display all versions(forexperts only) [T] Display outdated versions

Figure 5-1-13 Choose EtherCAT bus
For EtherCAT Master allocates the network port, double-click "EtherCAT _Master”>
“EtherCAT NICSettings > Browse, as shown in Figure 5-1-14shown.

= 5 Untitiedd bt
= (@ Device (CODESYS SofiMotion Win V3 x64) proe [ Autoconfig master/staves EtherCAT —
= 20 PLC Logic - |
B EtherCAT NIC Settings
= £} Application g
m Library Manager Overview Destination address (MAC) FEFREFFRFRFE Broadcast D Redundancy
[8) Pic_pRo PRG) Source address (WAC) (000000000000 | sasm_
= Log basiwin® !
ﬁ Task Configuration Network name
EtherCAT_Task (IEC-Tasks :
! & ok (P Tosks) EtherCAT /0 Mapping (@) Select netwark by MAC () Select netwark by name || Compare exact name
= & ManTask (EC-Tasks)
&) pic_prG EtherCAT IEC Objects 4 Distributed Clock Options
[ EthercaT_Master (EtherCAT Master) )
% SoftMotion General Axis Poal Status Cyde time 4000 5 =
nc offsat vl e %
Information Sl =

Figure 5-1-14Assign network port
Tip: Before assigning the network port, you need to download the project to the controller
Manually IO Add the module to the device tree, right-click "EtherCAT Master">"Add Device",

select "EC-8800-CONN”, as shown in Figure 5-1-15shown.
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Name [EC_8300_CONN_V1
Ackon

(W) Append device () [psert device Lpdate device

Name Vendor
= Feibuses
= e EtherCAT
" e Sve
# [l Sosch Rewroth 4G
+ [ Burkert Weske GmbH Co, KG
+ [ Contral Technioues
+ [ DECOWELL Automation Ca., Lid
= [ DECOWELL AUTOMATION CO.ATD,

DECOWELL AUTOMATION CO. LTD.
IC ecoso04amed vao DECOWELL AUTOMATION CO, LTD.

d DO-MINNYL 3

l:hcmc\:m VL3 | DECOWELL AUTOMATION CO. LTD.

Figure 5-1-15Add the module to the device tree
5. Download and monitor the program
Select "Online" > "Login to" from the menu bar,Confirm the download, then start the program and

select "Debug" > "Start" in the menu bar.

5.1.3 Sysmac Studio and EtherCAT Protocol I/O Module
1. Communication connection diagram, as shown in Figure 5-1-16shown.

OMRON PC
NJ301-1100 Sysmac Studio
EthercAT

EC-8800-CONN

Figure 5-1-16 Communication connection diagram
2. Hardware configuration is shown in Table 5-1-3Shown

Table 5-1-3Hardware Configuration Table

Hardware Quantity Remark
Programming Computer 1 Sysmac Studio
Controller 1 NJN301-1100
EC-8800-CONN 1 EtherCAT protocol 8DI/8DOModules
Network cable several

3. New project and equipment configuration
Open Sysmac Studio, select "New Project" and configure the device model and version

number, as shown in Figure 5-1-18 shown.
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| [ sysmac studio 64bin)

pen in Emulation Mode

Figure 5-1-17 New Construction
4. Install XML Description File
As shown in Figure 5-1-17 Open Sysmac Studio's ESI library, click "Install (file)", Select

the XML file and confirm, then wait for the installation to complete.

Multiview Explorer
new_Controller 0w |

s and

Calculate Transmission Detay Time of the Master

Import Slave Settings and Insert New Slave

sscription Clear All Settings

Export Configuration Information
Output to ENS File
- Export All Couplers’ /O Allocations

Figure 5-1-18 Display ESI library
To add an adapter, double-click "EtherCAT" in the Multiview Explorer, select "FS Series" in
the Toolbox, and then select "EC-8800-CONN-V3" at the bottom of the Toolbox, as shown in
Figure 5-1-19.
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(Bl riew Project - new Contraller 0- Sysmac Studio (84bit) - ###ese2 Miemal Editon nuss - 158 days |eft #esssass - a b

I Vi e = 1=

& & a i s @3 [

Figure 5-1-19 Adding Modules
Click the online icon, right-click the mouse on the icon of the master device, and select
Write Slave Device Node Address (the default node of the WELL-LINK EtherCAT slave

device is 0, so the node number must be set), as shown in Figure 5-1-20shown.

Collapse All

Calculate Transmission Delay Time of the Master

l Write Slave Node Address I

COin Gied IeigE withs ACIIGH TVCTWTR CONRGA G G

Get Slave Serial Numbers

Display Diagnosis/Statistics Information
Display Production Information

Display ESI Libwary

Figure 5-1-20Node address write
Note: After writing the node address, the device needs to be restarted for the node address to
take effect.
After the device restarts, download the program to the controller. Select "Controller" >
"Transfer" > "Transfer to Controller (T)" in the menu bar, as shown in Figure 5-twenty oneas

shown, and execute the download.

38



FS Series Remote 10 User Manual Ml VY Rl

ller_U - Sysmac Studio (b4DIt) - #FFFFFFFF Internal bdition inuse @ 120 days 18Tl FFFFFFFF

Project Controller Simulation Tools Window Help

Offline Ctrl+Shift+W

Synchronize... Ctrl+M

Transfer.. »  ToController. —Ctr+T
Mode b From Contraoller... Ctrl+Shift+T

Stop Monitoring

CotiRocat

Figure 5-1-21Program Download

5.2 PROFINET Protocol

5.2.1 TIA Portal and PROFINET Protocol IO Module connections and configuration
1. Communication connection diagram, as shown in the figure5-2-1shown.

PC
S7-1511
TIA Protal V16
e[ JolF]
adGoa

PN-HHOO-CINN

Figure 5-2-1Communication connection diagram
2. Hardware configuration as shown in the table5-2-1Shown

surface5-2-1Hardware Configuration Table

Hardware Quantity Remark
Programming Computer 1 Install TIA Portal V16
Controller 1 S7-1511
PN-HHOO0-C1NN 1 PROFINET16DI/16DOModul es
Network cable several

3. Installation GSD document
Open TIA Portal V16, select "Options" > "Support Device Description Files (GSD)”, as

shown in the figure5-2-2shown.
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Tools

| Options.

Window Help

11

’- Support packages =

Settings he

\» Manage general station description files (G5D)

Start Autornation License Manager

T

#| Show reference text

| | Global libraries »
L

E 4
Figure 5-2-2Install GSD document

4. New project and equipment configuration

Open TIA Portal V16, select New Project and configure, as shown in the figure5-2-3.

Add new device b.$
Device name:
]
~ mceu i_h Device:
Ll L RERET. T
[l 5ES7 511-1AKO0-0ABD —
Contalléss [l 5E57 511-14K01-0880
Il 5857 511-1AK02-0480
— . 6ES7 511-1AL03-0ABO IS
» (@ cPuIsTICI BN
D » [@cPUISIZCI PN : —————
| ¥ (3 CPU 15131 P | Aweemos  [6S7511-1A01 0480
- ke verson: R -
— » [l CPU 1516-3 PIDP
—F—r— » [ CPU 15173 PNIDP Description:
g » (@ cPu 15184 PHIDP CPU wath display; work memary 150 KB code and
[ 3 1 kB data, 60 ns bit operation time, 4=<tage
1518-4 PNIDP
| E ;' TETRIS R AR T protection concept, integrated technology
e st ¥ _@ CPU 15184 PNIDP MFP functions: Moticn Control, closed4oop control,
tustems e L - et ity

Figure 5-2-3New Construction
Configure the device, switch to the network view window, expand the hardware directory

on the right, and select PN-HHOO-C1NNDrag it to the network view, as shown in the

figure5-2-4shown.
e 5 00 E G coonine F oo fp 8 IE X 1] 1 - i
5" Topology view  igh Network view ot Device view | Options
2 | nerwerk | 1Y Connections -] L3 reladions B | N3 9 CH[[H| @& = |NQ— twork overview 4] 0]
e 1 Yi Cevice v | Catalog
|~ = * ST-1SO0IET200MP station._| [<Srarch>
= [T it
CPU 5111 P
= [l PRDFINETIO
¥ @ Drnves
» @ Encoders
. » [ Gatewny
~mlio
» (@ oEC
= [ DECOWELL
= [ F5 Series
PH-OHOO-HZNN
PH-OSO0-HONN
[ Fr-osooiNN
Il F-s800-CONN
Hl F-s800-C1nm
[ Fr-BB00-C2NN
vy _ | — ) -
S r3 [ [1oo o ——i— i <] m| »
= (Fa. B

Figure 5-2-4 Configuring the device
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In the network view for remote 10 module assignment controller, mouse click |OIn the

module "Not assigned", select PLC_1.PROFINET interface_1, as shown in the

figure5-2-5shown.
PLC 1 PN-HHOO-C1NN '
CPU 1511-1 PN PH-HHOD-C1NN D6 HORM
I mn—«&ehu 10 controller

interiace_1

Figure 5-2-5Allocation IO Controller
Setting I/OModule IPAddress, in the device view, double-click the module to enter the

property view, as shown in the figure5-2-6shown.

| [ Tops v
g [mremoocinm rrsnocids] | B B LGS L] Sa 7 |
—
-
- | &3
el *|{7sn od  —g—— < + >

| 4 Properties —F‘q,!--'.. |1 Diagrostics

' Intemet protocol version d (IPwd)

(@) i # acdrse inthe peaject

wadsans| [ 132

Satnermuks | 155 24

mi e

Figure 5-2-6Allocation IP address
remoteAssign device names to I/0O modules. Right-click the module and select “Assign
device name” as shown in Figure 5-2-7. Select the interface type and update the list and

assign a name as shown in Figure 5-2-8.

Contigured PROFINET device
£ 4
FROFIHET device name 1 |2 N
Convered name: w1 0dfib
AT

HHHO-CTHN

PEHHOO-CHNN Qnllne access
nee Type of the PLRCmedace. | puis -
PGPCimiuriace. M TomcAT intel PO Ethernes adapter (Ggabr) (vt I 5

JC_1.PROFIMET I0-Syxle. .. = :
Device filter
[l Dinly show dewes of the tame e
[T Ginly shem devmes with bt paremeter setsngs
[ 1 Dnly vhow devices without names

=|-l et

Acaunible devices in the network

h P acdresz MACaddres  Devce rRGheT device rame Status H
e 192 A0 FRAGPIHC | PRIAMODTINN VT @ ok

Figure 5-2-7 Assigning a Device Name Figure 5-2-8 Write device name
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Select all devices in the network view and download, as shown in the figure5-2-9As
shown, after the program is downloaded, start CPURun and switch to online monitoring to

see if the communication is normal, as shown in the figure5-2-10shown.

oall Preview

9 Check before loading
Status ! Target Message Action
M @ ~ Rt Readyfor loading. Load 'PLC_T' [~
1 ¥ Protection Protection from unauthorized sccess
Devices connected to an enterprise network or directly to the b
internet must be appropristely protected against unsuthorized =
access, e.q. by use of firewalls and network segmentatian. For
more information about industrial security, please visit
1 http:iiwww siemens comiindustrialsecurity
Q » Stop modules The modules are stopped for downloading to device Stop all
(v] ¥ Device configurati... Delete and replace syster date in target Download to device
0 » Testand commiss.. Modules with active test and commissioning function can preven., Accept all
- - iv
<] i 2]
| refresh
Load | | Cancel |
Figure 5-2-10Program Download
FLE |
CPU 1212C PR-HHOO-CTNMN DP-NORM
PLC 1 -
P! PI (1 PROFINET I0-Syste__ m—scmt
+ 1 I

Figure 5-2-11Equipment Monitoring

5.2.2 Step7 Smart and PROFINET protocol IO moduleConnection and configuration
1. Communication connection diagram, as shown in the figure5-2-12shown.

S STEP 7 l:-"IC WIN
-Micro
(oc/oc/oc) SMART

#0008

PN-HHOO-CINN

Figure 5-2-12Communication connection diagram

2. Hardware configuration as shown in the table5-2-2Shown
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Table 5-2-2 Hardware Configuration Table

Hardware Quantity Remark
Programming
1 InstallSTEP7-MicroWIN SMART
Computer
Controller 1 CPU ST40(DC/DC/DC)
PN-HHOO-C1NN 1 PROFINETprotocol16DI/16DOModules
Network cable several

3. Install GSD document

OpenSTEP7-MicroWIN SMART, select "GSDML Management”, as shown in the
figure5-2-13shown.

5 .
ko Preview

5 Project || JCreate
ZH -l Page Setup
nt

& pou |

a‘_, Open Folder

awrioad, = | foinsert = [ Deiete = | F5] G2] | () ¥
NI [

| Manage general station description files
Intreduction

"GE0OML management” allows you to install and delste G5DML files for PROFINET.

Tsported GSDEL files

bl 12t B0k
Jeleeliaddn bt T ok

s e el R A

_
-I

E

Ingtall new GSDEL

s DesHon B F e, BB P BT peice

Figure 5-2-13Install GSD document

= H!E_[E.:
| | B
| | |

4. Assign device name

In the menu bar, select "Tools" > "Find PROFINET Devices". In the window that appears,
select the network card connected to the module and search for devices. Select the module

from the network and edit its device name, as shown in Figure 5-2-14.

Notice:

(O When selecting a network card, two options will appear for the same network card, as
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shown in the figure below. Here, select the network card without Auto.

Realtek PCIe GBE Family Controller. TCPIP, 1
Realtek PCIe GBE Family Controller, TCPIF. Auto, 1

@After assigning the device name, make sure that the device name used when configuring
the 10 module is exactly the same as the one assigned above; otherwise, the PLC will not be

able to communicate properly with the 10 module.

|k
ofiory PO Control  SMART Drive fird PAOFINET| Certificate || Optians|
‘ol Panel  Panel  Corfiguration ™ |  Devices | Management

A LTI TN e e T [ It R 1 -

set o [Deete - | 05 |

cemde e fiteitacs . Prass the "Ede” button o changs the devies nems of the salactad
[TwinCaT-Intel FCE Elhernet Adapter (Gigabt) V2 TCFR L * | device, Prass the "Fach Lights" buthon ta continucusly flash device
LED= t wsually hocate & mmeced devioe.

[l FRoFiET e MAC Address

la-amz

FB:ALIFE ER 2R3 Flash Lights

IP Addrecs
ST

L 1ea168.0.8 (pn2)

Subnet Mask

Default Gaevay
[19 360 o
Devica Nama {Chinesa, ASCH characters ‘s’ - 'z, '0'-'9, "' and

*=*, shauld not start with number, ', - o ‘part-rn=0..9),
shesdd oot sod sueh ' " =y

3 | [em2 Ede

2 CEearT arne: g

Figure 5-2-14Assigning a Device Name
5. New Project and Equipment Configuration
From the menu bar, select Tools > PROFINET”, select PLCThe role is the controller, as
shown in the figure5-2-15As shown, add IOmodule and assign a device name (which must
be the same as the device name assigned in step 4 above) andPAddress and confirm the

generation, as shown in the figure5-2-16shown.

e ] e e -

GeifPut Data| PROFINE] Web Motion  PID Comtrol  SMART Drive  Find PROFINET  Certificate || Options
iy Log Server IC.mtroIPanc-l Parel  Configuration ™ Devices Management L

;—_la PROFINET Configuration Wizard

O PROFINET network
MAINY 1= Controller[CPU ST30_plc200sma Introductio

Jram G

This wizard allaws you to configure a PROFINET network step
the project, which can be downloaded to the PLC together witt

PLC Role

Select 3 role for the PLC.

e
[+ Controkier

[ Foevice

Figure 5-2-15Select PLC Role
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PROFINET Configuration Wizard

[ con CPU ST30_plc200smart)
CONN-pn2
1[0 PH-HHOC-COMK(E)
i~ [T PH-HHOO-CONN(L)
-~ completion [
o {EH-HHI-CARNR

Device tabhle

pl=200smad

| 192 16621

The device table lists all devices that are currently configured for this FROFINET net
¥You can add devices from the device cataleg tree on the right.

Devica Nurnber
1
2
3
;
&
7
8
<

Add &l

Tipe Davica Nama ] IF Setting
PH-HHOO-CONK prd St by usar

[P Address
| 192,188 . 0 . §

>

Catalg
£ PLE S7-300 SMART
| i-PUSRZO

FU SR30
CPU SRAD
CFU SRED
P ST
CPU ST30
CPU T4
{ - cRUSTED
E- PROFINET-10
Evo
- DECOWELL

1 E PAEHHO0-CONN
i
-

Article no.: 000104

Wersion:

| GSDML-VZ, 35-FN-HHO0-CONN-Z0210630.2m|
DRsCrption;

G50ML-YZ.35-P-HHOO-CONN-
20210630.xml

Dacowell PH-HHDO-CONN Profinet Device

Figure 5-2-16Assign a device name and IP address

6. Program download

In the menu bar, select "PLC" > "Download", then in the communication window, choose

"Find CPU". Select the PLC to which you want to download the program, and proceed with

the download.

Note: When using STEP 7-MicroWIN SMART to configure PROFINET communication for

the S7-200 SMART, the CPU firmware version must be = V2.4. For firmware version V2.3,

an online firmware upgrade is supported. However, for firmware versions below V2.3, the

firmware must be updated using a memory card inserted into the CPU.

5.2.3 CODESYS and PROFINET protocol IO module Connection and configuration
1. Communication connection diagram, as shown in the figure 5-2-17 shown.

PC
Codesys V3.5

T

PN-HHOO-CINN

Figure 5-2-17Communication connection diagram.
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2. Hardware configuration as shown in the table5-2-4Shown
surface5-2-4Hardware Configuration Table
hardware quantity Remark
Programming
1 InstallCodesysV3.5
Computer

PN-HHOO0-C1NN 1 PROFINETprotocol16DI/16DOModules

Network cable | several

2. Install GSDdocument
Open CODESYS V3.5Software, select "Tools" > "Device Repository" from the menu bar,

as shown in the figure5-2-18shown.

;S : \ -
Edit Locations...

Location System Repository >

(C:\ProgramD ata\CODESYS\Devices)
V — .

Installed Device Descriptions

String for a full text search | Vendor

<all vendors>

Tools | Window Help Name Vendar WVersion Description
| @& CODESYS Installer... | + 3] Mscekansous
i) Library Repository... | * [ Feldouses
[z . z It = B raar devices : e
E_Li Device Repesitory... | Ij o #® Install Device Description
+ (24 pucs
I‘QJ Visual Element Reposttory I * & Softiaton drives - » « 3. » FSRCESE. » v O BRFSERTE
&l Visualization Style Repository...
W License Repository... BA v R
- OPC UA Information Model Repository... & WosEE ~ = W EE
W License Manager... PRiEr et o
; = (Ehter 1
Device License Reader... L L I R T i
IDEE | GSDML-V2.35-PN-HHOO-CONN-2021... f
Customize.. 2 R
Options... H =R
] -

Figure 5-2-18Install GSD document
4, New Project and Equipment Configuration
Open CODESYS V3.5Software, select New Project > Project > Standard project”, as

shown in the figure5-2-19shown.
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") CODESYS

=] Mew Project

{ Categories Templates
' Libraries i .
d
‘ Empty project  HMIproject | EEREQ] | Stendard |
{ project project w.. .'(
{
ia
] :0'
{ |
]
in
B close
A show h
|ﬂ project contaming one dewice, one spplication, and an empty implementation for ALC_PRG I
Messages - Totl |
Name !ummer.u L‘,:

Description | kocetion  [C:'Users\sangteo. hu'Desktop'piicodesys

| o

Figure 5-2-19New Construction

In the standard project window, select "CODESYS SoftMotion Win V3" as the device,

and choose "Structured Text (ST)" as the programming language for PLC_PRG, as shown in

Figure 5-2-20.

Standard Project ot

=

You are about to create a new standard project. This wizard will create the following
objects within this project:

- One programmable device as specified below

- & program PLC_PRG in the language spedfied below

- & cyclic task which calls PLC_PRG

- & reference to the newest version of the Standard library currently installed.

Device CODESYS SoftMotion Win V3 x64 (35 - Smart Software Solutions GmbH)
BLC_PRG in |Structured Text (ST) v
cance

Figure 5-2-20Select device and programming language

In the device tree, go to "Device (CODESYS SoftMotion Win V3)" > "Add Device", and add

both the Ethernet adapter and the PROFINET IO Controller, as shown in Figures 5-2-21 and

5-2-22.

Tip: When configuring PROFINET 10 in the native CODESYS software, if an error occurs due to a

missing library, the user needs to manually double-click the Library Manager. In the Library Manager

window, select and download the missing library—this process requires an active internet

connection.

47



FS Series Remote 10 User Manual

HNELJYYELL

Additionally, pay attention to the IP address and subnet of the network port connected to the 10

device. Make sure they are in the same subnet when setting the IP address of the 10 device to avoid

communication issues.

sces. > ¥ oA Action
5 Unstegs = {® Appand device O Update devics
= [ Device (CODESYS SoftMotion WinVwid) | -
= 3} PLC Logie & Cut |5tring for a full text search Vendor  <al yendors>
= L3 Applicatio By Copy MName Vendor Version Description
) rary | 5, Pecte + (@ stecetaneous
[8) rcep{ X Delete = (i) Fieldouses
= a Task Ca Refactaring » i AR CANbus
- ;,T [ Propertics.. ': gy EtherCAT
u '+ H Ethemet Adapter
‘M SoftMotion Gene 13 Add Object » P
3 Add Folder... - 3§ HomeaBuikling Automation
Add Device... ® 4 Modbus
Update Device... % =0 pROFEUS
7 Edit Object - PROFDET IO
Edit Object With... = B Edemet Adaoter
Edit 1O mapping @ etermet 35 -Srmart Softwore Schitons GmbH 4.1.0.0  Ethemetlnk.
impart mappings from CSV.. W B AOEDET D Devler
Export mappings to CSV.. - KSR PROCIETID Mkt
% Online Config Mode... -
Reset Origin Device [Device]
Simulation gemnn_b\rtategarv _D_Dhn_lav;ﬂerslonsgwmmmﬁi:{nls;]nmﬂgam_d VETSiOns

Figure 5-2-21Adding an Ethernet Adapter

Figure 5-2-22Add PRO

Devices .2 x Action
= (3 Lintitiadd = @ Appenddevice () Insertdevice  Fug deoce () Wpdate devies
= [ Deves (CODESTS SoftMotion Win V3 x64)
= Bl P Loge [Stiig for & full text search | Wendor <Al yendors >
= 3 Application MName Vendor Version Descripti
) Library Manager = [ Fedbuses
[ pLc_pre PRG) + = EtherNet/IP
= [ Task Configuration + {3} romeaBuikling Autamation
= @& MainTask (JEC-Tasks) 0 Modbus
& pLc PR = ¥ PROFINET ID
[# ethemet Etheme * 5 PROFINET 1D Device
% SaftMotion General Axis Pool = 5 PROFINET 10 Master
[Dprcontroler |35 . 4300  PROFIET

FINET IOMain Station

In the device tree, double-click "Ethernet" to assign the Ethernet port and configure the

IP parameters of the PROFINET IO Controller, as shown in Figures 5-2-23 and 5-2-24.

Tasks)
= [ Etremet fEtremen

Lﬂ Fi_Controfler (Pr-Controller)
‘4 Sofitation General Axs Pool (SaftMotion General

|Tap-Hindovs

[Sangfor aTru

{Bienens FLISTH Virtual Ethernet Adapter

TwinCAT-Intal T

Devices - 3 % 4] Ethernet x| (7] Device
= 31 Lnosie -
o [y = . - General
5 peven . N X . Metwork Interface | Browse... |
= [§ ] 1
Bl oo Etharnet Device 10 Mapping 1P sddress 192 .18, 0 . 1
= £} Application = E
) Liseary Manager Bthernet Device [EC Objects Sibosh maek R 2, 0
[E) mc_PrE prG) | Cisfault oatesay PV Y
= (@ Task Configuration keg Metwork Adaprers %
- MairTasi: (IEC-Tasks) Status Interfases
& me pre I Hame Deseription TF sddress -
= g Profinct 0 (EC Ta EFFETIE luctooch Taviea (Farsondl Area Fatvork) nooo
) PN _Controler ConmCyce ; I

192 169.0.%0

0,000
2001

Adsprar V2
xt VHIC

Bafaclt gatiwny | O
MG address

192 18
255 265 785 0 |
0

0. |

Cancel

Figure 5-2-23 Ethernet allocation network port
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Devices * 8 X [ Ethenat '@ Devics & Pn_controller x
= untteds .
= (§ Device (CODESYS Control Win V3 x64) I GenecH Station name | controlier
=&l PLC Logic i
o , raen Default Slave IP Parameter
Q Application
) Ltrary Marager Tapology First IPaddress 192 .18 .0 .2
[8] rc_PrG (PRG) ‘ Last P address 192 . 188 . D . 254
= Media Redundancy
(58 vask Configuraten Subnet mask 255 . 255 . 255 . O
= & MaiTask (IEC-Tasks)
§dl‘"l PLC_PRG e R Default gateway o .0 .0 .0

= @ profinet_CommunicationTask (IEC-Tag |
#) pN_Controller.CommCyde i
% Profinet_IOTask (TEC Tasks)

. m
i (3 PM_tontrolier (PH-Controller) |

PNIQ EC Objects
11O Provider / Consumes Status

% softMation General Axis Pool (SoftMotion Genaral

Log [ Application stop > Substitute values
4 Add te /0 mapping
‘ Status
Substitute Input-Data
‘ Information (®) Zero

() Last valid value

Figure 5-2-24Setting PROFINET 10 Master Station IP

Download the program to the controller and start it. Then exit login mode. Right-click

PN_Controller and select "Scan Devices". In the device window, select the module and

assign the device name and IP address, as shown in Figure 5-2-25.Then, copy the device

into the project, as shown in Figure 5-2-26.

Scan Devices

Scanned Devices

ign e
I0: Dx0021

Ervor: A valid IF is required

ID number MAC Address

Foi A4 FBi80 83187

IP Address Subnet Mask g;;]way

1BM  Auto-IP <

Eam OLITEYEnges To
nraisck

= Reset Blink LE-‘J\\‘ only unnamed stations

Figure 5-2-25Assign a name to IP address

Scan Devices m} =
Scunned Devices
Device name  Device type Station Name 1D number MAC Address IP Address Subnet Mask !
= den FR2-HDO-CLEN V3 dec 15800000015 Fo: A4 FB BO:B3-97 192. 168, 0. 62 26E. 255 265. 0
dea 1 nput Dutpat L EH00000035
< »
= , SOOW A1 ICETencEs ©0
&M Auto-IP <-- link LED  Set Name an{ | Shew only unnssed stations L TRt

Scan Derics

i

Cepy ALl Devices to Projec

Figure 5-2-26Copy the device to the project
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5. Program download and device monitoring

Download the project to the controller and start running and monitoring, as shown in the

figure5-2-27shown.

1 Linboisgd
1} Device [ornectad] (CODESYS Contral Win ¥3 ne4)
= [# AcLoge
= L Apphication [run]
.ﬂ Library Manager
\E] e pPRG (PRG)

Tasks)

152 profinet_[OTask (IEC-Tasks)
i Etherriet Etharnat)
@ Pr_cContraler (PH-Controder)
= ¥ dec PNZHHIOCINN VT
0 dec_1(2bytes trputjOutput)
‘& SoftMobion General Axis Podl (SaftMaton General Axis

PNIO 10 Mapping

PNIO IEC Objects

Ratus

Infarmation

Data hold time [ms)

VLAN ID
Phas
dass T

Settings
4 et 41§ Difault Values arjiesd AN Valus i Write A1l v
Parameters Value Data Type  Allowed Values Description
Inouts
= Channeld

Channed 0 Input Delay Yo Unsgned
= Chennel 1

hsrned 1 Tovs i Nilay Tme  imseeeds

Figure 5-2-27Program download and monitoring

5.3 CC-Link IE Field Basic protocol
5.3.1 GX-Works2 and CC-Link IE Field Basic protocol |10 module connections and

configuration

1. Communication connection diagram, as shown in the figure5-3-1shown.

LCPU PC
L02 GX-Works2
CC-Link IE BieidBasic
CI-S000-CNNN

Figure 5-3-1Communication connection diagram

2. Hardware configuration is shown in Table 5-3-1shown.

Table 5-5-1 Hardware Configuration Table

hardware quantity Remark
Programming Computer 1 Installing GX-Works2
Controller 1 L02
CI-HHOO0-CONN 1 CC-Link IE Field Basic Protocol 16DI1/16DO Module

Network cable

several
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3. Description file installation
Open the GX-Works2 programming software. From the menu bar, select “Tool” >
“Profile” > “Login”, as shown in Figure 5-3-1, and then select the description file that needs to

be installed.

es | Tool | window Help
1€ Memory Card L éﬂi §il t..s.!

Set TEL Dats/Connect via Modem

Realtme itor Function{Q
Ethernet Adapter Mcdule Configuration Tool.
Byilt-in 1/O Module Toal

Check Intelligent Function Module Parameter

Intelligent Function Module Tool

Predefined Protocel Support Function

Language Selection...

Prafile Management
Key Customize...

Figure 5-3-1Description file installation
4. New construction projects
Open the GX-Works2 software. From the menu bar, select “Project” > “New”, then
choose the PLC series, CPU type, and programming language. In this case, the L-series

CPU is used as an example, as shown in Figure 5-3-2.

Mew Project *
Series: fLeru -]
Type: |Lozo2P =]
Project Type: IStructured Project =l

W Lse Lsbe
Language: E - |
[oc | coxe |

Figure 5-3-2Select PLC type
To configure CC-Link IE Field Basic parameters, go to the left navigation window and select
“‘Parameter” > “PLC Parameter”. In the L parameter settings window, choose “Built-in
Ethernet Port Settings”, then set the IP address and subnet mask for the PLC master station.

After completing the settings, click “CC-Link IE Field Basic Settings”, as shown in Figure
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5-3-3.

D E.!H =i 'i ;}_’6 5 1 Parameter Setfing %
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Prajoct | :
[y o0y o | B TP Address Setng e Set Open Setting in
:l' s LA X | 3 > — | T Etamerc figur wndonw
T Input Format |DEC -
oy |
& 0§ Network Parameter 1P Address I ] N )
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Figure 5-3-3Setting PLC IP Address
In the CC-Link IE Field Basic settings window, check the option “Use CC-Link IE Field Basic”,

and then click “Network Configuration Settings”, as shown in Figure 5-3-4.

CC-Link |EF Basic Setting x

[~ Matwork Configurabon Setbng

Metwork Configuration Setting

Refresh Settng
[ Link 5ide | FIC Side
Dev. Heme | Pointz | Start End Dev Wame | Points | Start End

i 0|
R o oocal  oongf
3 o ooeo] oon|
R 0| aoog 0o0a

Please set the slave station first in Network Configuration Setting.

Please check the content if it is changed because the Poinis i changed based an the number of ocoupied
|_ponts of siave stabon,

-

+311

-
-
-

Requred Settings ( otSet [ Already Set)

Defailt | ek | [ Ed | cance |

Figure 5-3-4 Network Configuration Settings
Method 1 for adding modules: Manual addition. In the CC-Link IE Field Basic
configuration window, drag the I/O modules from the right side directly into the CPU area at

the lower left for configuration, as shown in Figure 5-3-5.
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B cC-Link IEF Basic Configuration

i CC-Link IEF Basic Configuration Edit View Close with Discarding the Setting Close with Reflecting the Setting
Detect Now | Link Scan Setting |

ﬂ ‘ ‘M Mode! Name 5[;3: Station Type |__.._3"-'“"m‘§.._ — _l_?.wvfﬁs\ﬂr_&t_lﬂglu_ 2 s
j - — ! | | Paints [ Start | End |Ponis| Start | End %! B GG-Link IEF Basic Module (Genere
I st et 0 Master Staton 5 GO-Link IEF Basic Module (Mitsub
@ Output Module

| € »
Host Station
STARD L
Al Connected
CTnunt:U ; [Outline]
Towl STA#:D 16-InpLt & 16-output(Digial /O)
FWb
Specification]
) Ethemet . CC-Link E Fleld Basic
< > |Self-contral: 'I_ﬁl-‘h:ut PMPENPN v
i *

Figure 5-3-5Manually add modules
Method 2 for adding modules: Scan modules on the network into the device configuration. In

the CC-Link IE Field Basic configuration window, select “Auto-detect connected devices”, as

shown in Figure 5-3-6.

ﬂ CC-Link IEF Baslc Configurathon

it View Close with Discarding the Setting Close with Reflecting the Setting
Detect How Il Link Scan setting |

CC-Link IEF Basic Selection |Find M 4 ¥ |

! o
me! StatonType - e }EF—(— TR AT
B Output Module

STAS1
Host Station |

Al Connacted |
Count:1 Outline] A
Total STA® 16~irput & 16-outputiDicital 1/0)

CI-HHO0-C il

L [Specification]
Ethermat | CO-Link E Fimid Bazic
<§ | > |Seli-cantrol: 16-input PNPENPN v

Figure 5-3-6Scan the network for modules
To modify the module’s IP address (default IP address: 192.168.1.88), double-click the
IP address field of the module in the CC-Link |IE Field Basic configuration window to edit it.

After modifying, right-click the module’s IP address, select “Online” > “Reflect Slave
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Communication Settings” to apply the IP address change, as shown in Figure 5-3-7. Finally,

click “Reflect Settings and Close”, as shown in Figure 5-3-8.

RX/RY Setting
Pants | Start | End

Ne. Model Name STA2 | Station Type

Moves Up

Moves Below

Change Module
Check 3

Online 4 Detect Now
Properties... Communication Setting Reflection of Slave
l Parameter Processing of Slave Station...

Figure 5-3-7Modification Module IP address
Tgﬂ;;‘;xw Edit View. M%Mhhkﬁﬁ Miﬁmh*ﬁql

(Cannected Count 1

5§

& : i . .
J nn.| Model Hame smi Station Type |—W“!T;m|9—!|-’:";‘s!ﬂ; Grougs o | RSVD 5TA | TF fddress Subret Mask MAC Address

v
J B | 0 fostStsbon D Master Station 192.168,3.39 255,155,550

%4

i e

Host Station

STARD 6

AF Connacted
Countil
Tota STAR:]

Figure 5-3-8Reflect settings and close
I/0 Mapping Configuration: In the CC-Link IE Field Basic configuration window, set the
starting address points for the remote I/O module’s inputs and outputs, as shown in Figure

5-3-9.
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PLC |PLC Systen | PLC File |Pecras Boot File Program |sFc e |1/0 Assigrement | |

PLC Name
|‘.'-|||||1|f'-'F;|-:.-:|.".l::':;! |‘\‘\..-|:Iit' r

. Builtdn Ethernet Port Setting

[P Address Setting B Set Open Setting in

Configuration window

Open Seting I
Input Format lCGC 'I "

CC-Link [EF Basic Setting

1P Address 3

Subnet Mask Pal 15 yyce the CC-Link IEF Basic

Default Router IF - Nietwork Configuration Setiing

Network Configuration Setting

Communicaton Dat
Refresh Setting

(% Binary Code | Tk Side

[Dev. Nama | Pointz | Start End
X & 0000 003F| 44
|RY €4 0000 [T
e 32| 0000]  O00IF| 4
B 32| 0000|  O01F| 4
Please set the slave station first in Network Configuratod

Please check the content if it is changed because the Pair
|_points of glave station.

[™ Danot respont Requredfettings { notSet /  Aready Set )

Defalt | check || Ed | Cancel

™ ASCII Code

[ Enable orline ¢

[ Disable direct ¢

Simple PLC Communication Satting 1P packet transfer seting

Simple PLC Communication Setting IP packet transfer setting |

Print Window... | Print Window Preview | Acnowiedge XY Assigment | Defaut | check | | End Cancel

Figure 5-3-9 10 Mapping Configuration
5.CC-Link IE Field Basic Output Point Mapping Method: Each slave occupies 64 points, i.e.,
64 DI and 64 DO. Here, the input and output points correspond to the starting addresses
X100 and Y100, respectively. The slave 1/0O point mapping is shown in Figure 5-3-10.

;Elé"g:;'i Remote IO Remote IO Remote IO Remote IO
Slave 1 Slave 2 Slave 3 Slave 4
Master 0
T m—m—— X100-X13F X140-X17F X180-X1BF X1C0-X1FF
P PPING: | v100-v13F Y140-Y17F Y180-Y1CF Y1CO-Y1FF

Figure 5-3-10Slave IOPoint Mapping

6. Diagnose communication status
After completing the parameter configuration, download the project to the PLC. You can
then check the communication status through online diagnostics. From the menu bar, select

“Diagnostics” > “CC-Link IE Field Basic Diagnostics”, and view the status of the slave 1/0
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modules in the CC-Link IE Field Basic diagnostics window.

5.4 CC-Link protocol

5.4.1 GX-Works2 and CCLink protocol IO Module connections and configuration
1. Communication connection diagram, as shown in the figure5-4-1shown.

PC
GX-Works2

PLC

CCuink

CL-HHOO-CONN

Figure 5-4-1Communication connection diagram
2. Hardware configuration as shown in the table5-4-1Shown

surface5-4-1Hardware Configuration Table

Hardware Quantity Remark
Programming Computer 1 InstallGX-Works2
PLC 1 Support CCLink protocol
CL-HHOO-CONN 1 CC-Linkprotocol 16DI/16DOModules
CCLink communication line several

3. New project and communication parameter configuration

Open the GX-Works2 software and select the actual CPU model used on site. Then, in the
project’s left navigation pane, go to “Parameter” > “Network Parameter” > “CC-Link”. In the
CC-Link parameter settings window, configure the CC-Link slave settings as shown in

Figure 5-4-2, and the CC-Link network parameters as shown in Figure 5-4-3.
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[Master Staton -

| {3 Struetured Data Types
| {5} Local Device Camment
-4 Device Memory

" # Device Initial Value

MamberofModdes |1 7] Boards  Blank:hoSetting [ Setth the CC-Link

Parameter settings completed.

Mecessary Setting( No Settng [ Akeady Set ) Setif itisneeded( No Seting | AkeadySet)
Settng Item Detads: Check the parameter settings.
Print Window.. | Pt Windan Adoaweds I‘"l Clear | Chedk | End. I Cancel I

Figure 5-4-3 CC-Link parameter settings
4.CC-Link module communication address allocation diagram
FSSeries CCLink protocol remote IOModule as CCLink remote 10Station, each module
occupies 32Dland32DO(Mitsubishi CCLink protocol), module address allocation and use, as

shown in Figure 5-4-4shown.
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Occupied Address: X1000-X101F  Occupied Address: X1020-X103F

¥Y1000-Y101F ¥1020-Y103F
Used Address: X1000-X100F Used Address: X1020-X1028
¥1010-Y101F Y1038-Y103F
CCLink
PLC CL-HHOO-CONN CL-8800-CONN
X1060-X107F X1040-X105F

Occupied Address: y1pgp-y107F Occupied Address: v1040-y105F

Used Address: Y1060-Y107F Used Address: X1040-X105F

CL-0S00-NONN CL-S000-CNNN

Figure 5-4-4 CC-Link address allocation

5.5 DeviceNet Protocol

5.5.1 CX-one and DeviceNet protocol IO Module connections and configuration
Tip: There are two configuration methods for communication between CX-One and EX-1010:

manual and automatic. For details, please refer to items 4 and 5 in section 5.3.1.

1. Communication connection diagram, as shown in Figure 5-5-1shown.

OMRON PC
czm/oiw-

RN Sysmac Studio

Deviceet™>>

DN-HHOO-00NN-E

Figure 5-5-1Communication connection diagram
Note: The power interface on the DeviceNet adapter requires a separate DC 24V
power supply. Additionally, terminal resistors must be installed at both ends of the

network. The wiring method for the terminal resistors is shown in Figure 5-5-2.

V+
CH

E SLD
C

Figure 5-5-2Terminal resistance wiring

et

T —

[$)]
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2. Hardware configuration as shown in the table5-5-1Shown

surface5-5-1Hardware Configuration Table

Hardware Quantity Remark
Programming Computer 1 CX-one
Controller 1 CJ2M/CJ1W-DR2M
DN-HHO0-CONN 1 DeviceNet protocol 16DI/16DOModules
DeviceNet communication line several

3. Install EDS document

Open the CX-Integrator configuration software, select "Tools" > "DeviceNet Tools" >
"Edit Configuration File" > "Vendor ID/Equipment Type Table’, as shown in the
figure5-5-3shown.

neny Tools | Windows Help

Start Data Link
Start Routing table

NT Link tool
DeviceNet tool
Controller Link tool
Ethernet tool(H)

vy v v ¥

CPe file L
[ eos e > T
Update DTM Catalog

Create

-

Options

84 Find

Figure 5-5-3Install EDSdocument
4, Device Configuration (Auto Scan)
Open the CX-Integrator configuration software, in the menu bar select 'Network' >
'‘Communication Settings', and choose the PLC model as 'CJ2M (CPU Model: CPU31)", as

shown in Figure 5-5-4.
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General |

CPU Type
[cpuat -
|RelayDerice
Tivise o Total Program Area Size
JC_TZI\‘[ E] Settings... | | 7 ) |< K [Step] J I~ Read Only
Hetwork Tvpe
|Cvntrollel' Link L] Settings. .. Expansion Memory
[32kw 11 Banks) | Readonly
File Memory
|'\h'r & J [T Re
Timer [ Clock
114 Cancal Halp
=] @ I
Make Default

Figure 5-5-4Configuration CPU
Automatic scanning, click the 'Online Work' button, double-click the DeviceNet
[CJ1W-DRM21] network (-), node (1), unit (0), and set the network name, then confirm the
transfer as shown in Figure 5-5-5. Double-click DN-HHOO-CONN to check if the Omron PLC
can detect the DN-HHOO-CONN slave station.

1t Network Component Tools Windows Help
& | %,
B FOE S

Figure 5-5-5Automatic scanning
5. Device Configuration (Manual Configuration)
On the right side, click "New Project", select "Insert Network", and select "DeviceNet" as

shown in the figure5-5-6shown.
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| Wizard - Network/Component Settings b |

Netwark |
_'_f}j ! |'— MName | Description
§ I:EEEE! I CompoNet Fieldbus Network{Compoet]
Prarn CompoWayF Serial cor i

Insert Network

NTLink Senal connectionlfor display:h

Delete SysmacLink PLC level Netwark(SLIQ

Transfer[PC to Network]

Transfer[Network to PC]

Rename Network o | T - ‘ —l o " J

Change Network Address

Figure 5-5-6Insert Network
In the inserted network, add Devive firstNet Communication Module CJ1W-DRM21, then
add 10Device, right-click the network icon > "Insert Component", select DN-HHO0-CONN, as

shown in the figure5-5-7shown.

| Wizard - Metwark/Component Settings *

Component l

Component Tupe
= 4 EDS(Devicalet)
= i Vendor

~ (& DECOWELL
= i Communi cations hda .
+ - &) ]

+ ) (MROR Corporation
+ 1 DavieaType

Integrator " BDS (Devi calat)

Figure 5-5-7Add Remote IOModules

6, download configuration information

Right-click "CJ1W-DR2M” icon, select “Parameters” > “Edit”, as shown in the

figure5-5-8shown.
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G §

_P_arameter

4 K Wizard

ir L _
ﬂ Load...
| %4 Save
<]
{ i L
Register to another component dE ol
Export '|
& Cut {

Figure 5-5-80pen parameter editing

In the Edit Device Parameters window, select the "Register button" to register the slave

device, as shown in the figure5-5-9After successful registration, you can see the PLC

internal address corresponding to the input and output of the slave 1/0 module. Finally, click

the "Download" button to download the configuration information to the PLC, as shown in the

figure5-5-10After the download is complete, you can see that the NET RUN indicator on the

adapter is on and the SYS indicator flashes once per second.

1
Edit Device Parameters

Communication Cycle Time

x |

I Message Timer | Slave Function

General | yOAlocation(OUT) | 1/0 Allccation(IN)

~Unregister Device List

#  |podug Name

| Out size | In size |

& 02 DN-HHOO-CONN

| 2Byte 2 Byte

Register Device List

| > | - | ¥ Autc allocation as is registered.

= Product Name

| Outsize | Outch [insize [Inch [ |

Figure 5-5-9Slave Device Registration
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Edit Device Parameters x |
Communication Cycle Time i Message Timer | Slave Function I

/0 Aliocation(OUT) | 1/0 Allocation(IN) |

Unregister Device List

| # I Product Name | Out Size| In Size |

& I - | ¥ Auto allocation as is registered,
Register Device List

? # ]. Product Name .i OutSizel Ot ch | In Size ! InCh ! [ & !
|#9#02 DN-HHOO-CONN  2Byte  3200:B.. 2Byte  3300:..

Advanced Setup.., I Register/Unregisterd I

ae | om |

Figure 5-5-10Download Configuration

5.6 CAN open protocol

5.6.1 AutoShop with CANopen Protocol 10 Modules
1. Communication connection diagram, as shown in Figure 5-6-1shown.

PC

HaY AutoShop

CANopen

CA-8800-CONN

Figure 5-6-1 Communication connection diagram
Notice:The power interface on the CANopen adapter requires a separate DC 24V power
supply. Terminal resistors must be added to both end modules of the network. The wiring

method for the terminal resistors is shown in Figure 5-6-2.
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Figure 5-6-2 Terminal resistance wiring
2. Hardware configuration is shown in Table 5-6-1Shown

Table 5-6-1Hardware Configuration Table

Hardware Quantity Remark
Programming Computer 1 AutShop
Controller 1 H5U-A8
CA-8800-CONN 1 CANopen 8DI/8DO Modules
Communication line several

3. Create a project

Open the AutoShop software, select the actual model corresponding to H5U and create
a project. In the configuration panel on the left side of the project, double-click “CAN
(CANLInk)”, change the protocol type to CANopen, and set the communication baud rate to

125 kbps, as shown in Figure 5-6-3.

Ll B || 5 mam <
M| Tomp Project [H3U-AB] Hak L Hut Capramnt
-l Systern Variabl= Tabl) I
7 CAN Config X
1 5 Tt E H
: = T CAN Boct Sebting
[ L i Variable Table Het 3 8
{58 s . Protocol
A-H +| Programming
i £r-3B Program Black
11 Tt d u e + = ,
I 5 [ Z 4 AcANapen! [ candink [CJCAN Free Srotocal
et
Communicate Param
Wt & H . i
1 Staton Mo,
7] Upper computer setting Dial Setting
Her 7 1
Station: |63 1 == Gtation MO, <= 63
Wer B !
Baud Rate
L Li [l Upper computer setting Cial Seming
et il Baud Rate: |500 | Kbps
War 1L ] B . =
Pleass right cick to add the main config,
Het 12 B
o] o

Figure 5-6-3 CANOpen communication parameter settings
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Install EDS document

In the configuration panel on the left, right-click “CAN (CANopen)” and select “Add CAN
Configuration.” Then double-click the CANopen configuration. In the blank area of the
CANopen device list on the right side of the view, right-click and select “Import EDS,” as

shown in Figure 5-6-4.

¢t Manager n % [4] ~ FMAIN Z8 CANOpen Config x
T 7 ! -
Bl Tomp Project [H5U-A] =-F] CANopen Metwork Confi =B W
a--ﬁ' Systern Variable Table |:] H5U-A8 =[] Inovance
=-E] Glabal Variable [ HsU PLC
24 Structure --[5 Easy PLC
(=] Element Table B H3U PLC

@ Eunction Block Instances B MD280/MOS00 V111

Q Variable Takle --[F MD3IBO/MDSD0 V112
+{i] Programming |5 MDE10_ INV_ Y1 2
- 28 Program Block B MDE10 INV V15
LB MAIN -5 MD&10 INV_V3.0

SBR_ODT -[F MD810 REC VC.2

LB T oo [ MD810 REC V12.4
-~ &% Function Block (FB] --[E MDBI0_REC V13.0
.= Function (FC) .-[F 18620 V055

o [ Config [ sV630C Vi
- Input Filtering - SVee0C_V1a
A7) COMO B 15810Vt

I.‘|;|Fi CAN({CANopen)
@ CANCpen Config

[ Ethernet
=
-4 Elecrronic Cam

n& Meotion Control Awxs
{?.j Axis Group Settings Import Device ¥ML
i EtherCAT

[fFs EtherNatap
=-5/% Yariable Monitor Table

MAIN

Uninstal| ECS

Figure 5-6-4 Install EDS document
Right click "CAN (CANLink)" and select "Add CAN Config", and add CA-8800-CONN

module, as shown in Figure 5-6-5As shown;
R .
..... E| H5U PLC
..... E| Easy PLC
----- [E] H3U PLC
----- E] MD380/MDS00 V111
----- E] MD380/MDS00 V112
----- E| MD810_INV_ V1.2
----- E] MD810_INV V1.5
----- E] MDa10 INV V3.0
----- E] MD810 REC VC.2
----- E| MD810_REC V124
----- E] MD810_REC V13.0
----- E] 15620 V056
..... ] sve30C V1.1
..... E] Sv680C V1.1
..... B 15810 V1.1
=-[E DECOWELL AUTOMATION CO.LTD.

oW =f C2-2800-coNN

m

CA-8800-CONN
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Figure 5-6-5Add CANopen module
Double-click the CA-8800-CONN module in the configuration panel, and configure the Node
ID (Note: The Node ID must match the actual address set by the DIP switch; otherwise,
communication will not function properly), as shown in Figure 5-6-7. Then check the 1/O
mapping addresses of the actual CANopen module, as shown in Figure 5-6-8.

slave Node  Receive PDO  Send PDO  Service Data (

Convention

Mode1D: |0 =

[CJEnable Expert setting \

Figure 5-6-7Setting Node ID

CA-8800-COMNMN >

Slave Node Receive PDO Send PDO  Service Data Objects Débug IO Mapping MoHule infarmation

Yariable Mapping Index: Subindex Bit Length
— D700 Receive PDO 1 Mapping 1621600 8
D7000_L Write Outputs 0x1 to Ox8 - 16#6200:1 8
-— D7400 Transmit PDO 1 Mapping 16#1A00 8
D7400_L ‘Read Inputs Ox1 to 08 16#6000:1 8

Figure 5-6-8 I/OAddress Mapping
Tip: In this example, D700_L stores the values of the 8-channel digital outputs, while

D7400_L stores the values of the 8-channel digital inputs.

5.6.2 InoProShop with CANopen Protocol 10 Modules
1. Communication connection diagram, as shown in Figure 5-6-9shown.
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AMA401- PC
1608 InoProShop
CANopen

CA-8800-CONN

Figure 5-6-9Communication connection diagram
Notice:The power interface on the CANopen adapter requires a separate DC 24V power
supply. Terminal resistors must be added to both end modules of the network. The wiring

method for the terminal resistors is shown in Figure 5-6-10.

+
C

E SLD
CL

Figure 5-6-10 Terminal resistance wiring

oret

2. Hardware configuration is shown in Table 5-6-2Shown

Table 5-6-2Hardware Configuration Table

Hardware Quantity Remark
Programming Computer 1 InoProShop
Controller 1 AM401-1608
CA-8800-CONN 1 CANopen 8DI/8DOModules
Communication line several

3. Install EDS document
OpeninoProShopProgramming software, select "Tools" > "Device Library" in the menu
bar, select "Install" in the device library window, and select the EDS File, as shown in Figure

5-6-11shown.
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Online  Debug | Tools | Window Help
Package Manager... I -__]Fb IffJ I:
InoPkgManager
Library Repository...
InoProShop Tool

Network Config

ClE® A a

2[m)

) »
2rpting Mapping

Customize...

Options. ..

‘ | Information

E e ey

Location:  |System Repository ~ Edit Locations...
{€:\Inovance Control\InoProShop!|INOYCODESYS\Repository |Devices)

Installed device descriptions:

String for & fulltext search Vendor: | <all vandors> v Install...
MName Vendor Vers & Uninstall
= Cifl CANopen Export..
= €ifl Remote Device
5 15580 Driver Shenzhen Inovance Techrology Co., Ltd Rewvisi ¥
| € >
| = @ C:\Users\xinyao.i\Desktop\F A BBETE4\3. IREE 7 HE\CA-8800-CONN, eds
@ Devics "CA-B500-CONN" installed to device repository.
Details..,

Figure 5-6-11Install EDSdocument

4. Create a project
Open the InoProShop programming software, create a new project, and select the actual
corresponding CPU model. In the project configuration panel on the left, double-click to open

“LocalBus Config,” then click on the CPU and select “CANopen Master,” as shown in Figure

5-6-12.
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ﬂ Device

| ;;f Network Configuration

= Untted1s
= [{] Device (AM401-CPU 1608TP/TN)
QO Fauit Diagnose
= a’? Netwark Configuration
¥4 canopen config

.2 Locaibus Config

= B0 PLC Logic
= I} Application

&  DifferentialMonitor
m Lbrary Manager
[E] PLC_PRG (PRG)

= _.E Task Configuration
=& canopen

& canopen_Task

T

-

LocalBus | % Refresh

= Copy (& Paste

Uelete

¥ Hardware Configuration x | ] CANOPEN

Undo Redo & Zc

AT 0
[ ]Modbus Mas ter

o [“|CANopen Haster

[[JiMdodbusTCP Master

JEtherCAT

[(JEtherCAT Master
_FEtherNet/IP
[(JEtheret/IP Master []EtherNet/IP Slave

[]dodbus Slave

[]CaNlink Master

[v]ModbusTCP Slave

Figure 5-6-12Configuration CANopen

[]Free Protocol
[J€ANlink Slave [1E

[Jdelsec Master

In the device list on the left, double-click “CANOPEN (CANopen Master)” to configure

the communication parameters of the CANopen master, as shown in Figure 5-6-13.

| /([ Device '€ Network Configuration 9 Hardware Configuration

CANOpen Master Metwork Management

Node ID: 127 +
CANopenMaster IO Mapping

Baudrate(Kbit/s): 500 ™
Status

[ ] No access to SDO,NMT When program is running
Information

Autostart CANopenManager

Paolling of optional slaves

Sync
71 Enable Svnec Praducina

] canopPen x

Check and fix configuratiol

Start Slave

NMT Start All(if possible)

Heartbeat
M1 Enshlae Hasrtkhast Dead

Figure 5-6-13 Configuration CANopen master station communication parameters

Double-click to open “Network Configuration.” In the configuration window, drag and

drop “CA-8800-CONN” from the third-party manufacturer list under the CANopen device list

into the network device list, as shown in Figure 5-6-14.
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iy Delete $5Undo Rede
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35 Seral Port
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7, EtherNet/IP Port
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Figure 5-6-14Add CANopen module
In the device list, double-click the CA-8800-CONN module and configure the Node ID (Note:
The Node ID must match the address set by the physical DIP switch; otherwise,
communication will not function properly), as shown in Figure 5-6-15. Then check the 1/0

mapping addresses of the actual CANopen module, as shown in Figure 5-6-16.

Devices * 3 X : @ff" Metwark Configuration !—,! Hardware Configuration ﬂ CA_8B0O0_CONN X
= Untited2! Slave Parameter Configuration Seeedl T
= [ Device {AM401-CPU1S0ETP/TN) Naode ID: 1 : |
9 Device Ciagnose Receive PDO
+ % Network Configuration 1 [C] Enable Exert Settings
Send PDOD

# 2l pLC Loge
| Respurces List
‘3 SoftMobon General Axis Podl
B ri6H_SPEED 1O (High Speed 10 Modue)
(W] MODEUS_TCP (ModbusTCP Device)

| H ca_ss00_CoMN (CANopen Slave) |

Service Data Object [] Enable Sync Produding

Debug
CANopenSlaver 10 Mapping
| Status

Infarmation

Figure 5-6-15Setting Node ID

K| @f MNetworkConfiguration [Py Hardware Configuration

4] ca_sso0_conn x

= Racsive POO Variable Mapping Channel Address Type Default Value Unit  Description
| =" Virite Outputs Ox1 to 0x8 %081 LSINT Receive PDO
Send FDO "y BitD w010 BOOL
" Bit1 L ¥ S BOOL
Service Data Object LA e Lz BOCL
Deby " Bit3 %QNL3  BOCL
| “» Bits HQKLA BOCL
| CANopenSlaver I/0 Mapping ) BitS WX 1.5 BOCL
"» Bith WQHLE BOCL
" Bit7 wOXLT  BOOL
Information =y Read Inputs Ox! to Ox@ SI82 USINT Send PDO
» Bitl %IX2.0 BOCL
*» Bit %INZ. 1 BOCL
“» Bit2 %INZ,2 BOCL
*» Bit3 %liZ,3 BOOL
» Bit4 HliZ.4 BOCL
“» BitS WIX2.S BOCL
“*» Bits SIZE BOCL
» Bit7 %RIX2.7 BOCL

Figure 5

-6-16 I/OAddress Mapping
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5.7 EtherNet/IP Protocol

5.7.1 KV STUDIO With EtherNet/IP protocol IOModule connections and configuration
1. Communication connection diagram, as shown in Figure 5-7-1Shown

PC

KV=7500 KV STUDIO

EihorattP 2>

EI2-HHOO-C1INN

Figure 5-7-1Communication connection diagram
2. Hardware configuration as shown in Table 5-7-1Shown

Table 5-7-1Hardware Configuration Table

hardware quantity Remark
KV STUDIO,IP Setting
Programming Computer 1
Tool software
PLC 1 KV-7500
EtherNet/IP Protocol
EI2-HHOO-C1NN 1
16DI1/16DOModules
Communication line several

Module IP Address Settings

Open IP Setting Tool software, select the network card connected to the module, and

scan the online 10 Module, as shown in Figure 5-7-2shown.

| State MAC addr Device name IP addr Next power on

|F8.A4.FB.00.13.82 | EI2-HHOO-CONN(EtherNet!P | 182.168.0.11 | Start with fixed IP | IP a:l(‘)r ..

n Scan EtherNetIP
devices(A)...

< >

Exit(X)

[“] Display detailed information(D)

Figure 5-7-2Scan Online IOModules
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Select the module in the scan list whose IP address needs to be modified (Note: the module
is set to BOOTP by default at the factory and has no IP address. After setting the IP address,

be sure to select "Static IP" as the startup mode), as shown in Figure 5-7-3.

B 1= setting Too O
File(F) Communication{C Setup{S] Language(l)] HealpH)
State MAC addr | Device name IP addr | Wext power on m Setup
FEASFBE0013B2 | EIZ-HHOO-CONN(EIherNeliF)| 192.168.0.11 Start with fixed IP 1P addr ). \\
H Scan EtheretiP
A
Setup IP addr. Sevigesial
Please set the IP address.
MAC addr FBA4FB:00:13.B2
Device name El2-HHOO0-CONN(EtherMNatiP)
< >
1P addr (required)(l) 92 , 168 . 0 ., 11 |
[ Display detai l Exit(x)

Host name (optionalH)

IP addr. seting at

next power on(l) |Start with fixed IP

‘Search avallable IP addresses(El..

Figure 5-7-3Setting IP address
Suggestion:
Since the module does not have an IP address by default, configure the PC's network adapter
IPv4 settings to be in the same subnet as the IP address you intend to assign to the module
before setting the module's IP.
4. Install EDS document
Open the KV STUDIO software, create a new project, and double-click “EtherNet/IP” in the
project device tree to open the EtherNet/IP settings window. In the EtherNet/IP settings

window, go to the menu bar and select “EDS File” > “Register,” as shown in Figure 5-7-4.

@ Etheriet/IF  R30000 DM10000 B, EtherNet/IP settings

. Unit configuration switching

File() Edit(E) Settings(S) View(V) Convert(C]‘EDSﬁl-e{D} Comrnicationth) Fool
s0 i 4 ; Reg(l)... |

Delete(D)

Searcn(S)...

Edit comments(E)...

Add to scan list{A)

Display latest revision(V)

rtylr)..

unction B

Figure 5-7-4Install EDS document
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5. New project and equipment configuration

Open KV STUDIO software, create a new project, and double-click “EtherNet/IP” in the
project device tree to open the EtherNet/IP settings window. Manually add EI2-HHOO-C1NN
to the EtherNet/IP list, as shown in Figure 5-7-5.

_ S - _ S - . _ . - _ - - - —
L Ey EtherNet/IP setting — = < F
File(F) Edit(E) Settings(S) View(V) ConvertiC) EDS file(D) Communication(N) Tool(T) Help(H)
OF DB = LB ey hE @
- o 185 .168.0.10 EtherNet/IP unit L]
Unit fist(1) | Unit setting(2)
B | 7E 5 |
- |EDS £i1. .. |m

1.

i BV -1120 1.1 EtherNe...
Initial adapter settings X s 1.1 [Chassis...
. 1.1 [EtherNe...
Node address(A) | 1| 1.2 |8-podnt...
n = 1.2 |16-poin...

IP address(l) | 192 . 168 0 ol | o E
1.2 |32-poin...

Connection name [E] 1.2 |8-point... ¥
Exclusive Owner B vour >
M) and 1€ point outpuc

Figure 5-7-5Manually addEI2-HHO0-C1NNTo EtherNet/IP List
Scan the EI2-HHOO-C1NN adapter online (first ensure that the online module and the PLC

are on the same subnet). In the EtherNet/IP settings window, go to the menu bar and select

“File” > “Auto Configuration,” as shown in Figure 5-7-6.

Froject B X Man x

File(F) Edit(E) Settings(S) View(V) Convert(C) EDS file(D) Communication(N) Tool(T) Help(H)
LN CRARY RBE @

tsetting(2)  Search unit{3) |

0% 0 | G Displey all

Unit name IP address | MAC

Search unit settings x|

Search start address(T) 186 0 0

Searchendaddress(E] | 192 . 186 . 0 . 255 |

[+ Search unit withaut IP address(U)

Request acceptance time(Q) |15 5 |
Search(E)} Cancel

Figure 5-7-6 Online EI2-HHOO-C1NN Module scan up

73



FS Series Remote 10 User Manual Ml VY Rl

Apply configuration and download configuration and program to PLCand monitor the

module operation status, as shown in Figure 5-7-7 shown.

-— * @ w2 WL 2T ¥ MR =1 =T
A= Z2EBURTSsE @ > Ll = Comments Comment 1
Project B X Main b4
2 | 2 3 4 5 6

i == Sensor 10 monitor:iV-7500[0].E12-HHO0-CONN(1] = >
Z I
£ 0 B E B iR S
g _I_W_D:g Current value | Display format ) Comments |l

i~ T R 0 DEC 16BIT KV-750001071 .EI2-EHOO-CORN[11IN 100701

woa2 0 DEC 16BIT KV-7500007 .EI2-HHDO-CORNI1100T 1017107

v

AN EXSCUTion ! I

Figure 5-7-7Run and monitor

5.7.2 Machine Expert and EtherNet/IP protocol 10 Module connections and
configuration

1. Communication connection diagram, as shown in Figure 5-7-8Shown

PC

WL Machine Expert

EthertotP>>

EI2-HHOD-CINN

Figure 5-7-8Communication connection diagram
2. Hardware configuration as shown in Table 5-7-2Shown

Table 5-7-2Hardware Configuration Table

hardware quantity Remark
Programming Computer 1 Machine Expert,|P Setting Toolsoftware
PLC 1 M241
EI2-HHOO-C1NN 1 EtherNet/IP Protocol 16DI/16DOModules
Communication line several

Module IP Address Settings

Open IP Setting Tool software, select the network card connected to the module, and

scan the online IO Module, as shown in Figure 5-7-9shown.
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cation(C) Setup(S) language{l} Help(H)

Next power on  [ep—

Start with fied IP | |l2¢1|Pada;.m..

| ag ScanEmeriene |
ln devices(A)...

[ Display detailed information(D) ‘

Figure 5-7-9Scan Online IOModules

Select the module in the scan list whose IP address needs to be modified (Note: the
module is set to BOOTP by default at the factory and has no IP address. After setting the IP
address, be sure to select "Static IP" as the startup mode), as shown in Figure 5-7-10shown.

u P 5etting Tool O X ‘

File{F) Communication(C) Setup(S) Language(l) Help(H)

State MAC adar | Device name : |
& ¥ 3B B2 1 8.0 ‘?&wn |

Setup IP addr,

Please sel the IP address.

FRA4FBOD 13A2

MAC addr.

Device name |E12-HHO0-CONN(EtherNatiP)

1P 304 (required)(l) || 92 . 18 . 0 ., 11 ]l

Host name (optionalfH) | |

IP addr. sefing al ]
it r onih) I (Start with fixed IP Pl

Search avallable IP adoresses(E... | OK I

Figure 5-7-10Setting IPaddress

Recommendation: The module does not have an IP address by default. Before configuring the
module's IP address, first set the PC’s network adapter IPv4 to the same subnet as the IP address
you intend to assign to the module.
4. Install EDS document

Open Machine Expert V2.0Programming software, select "Tools" > "Device Repository"
in the menu bar, and select "Install" in the Device Repository window, as shown in Figure

5-7-2As shown, select EDS file "EI2-HHO0-C1NN" and confirm the installation.
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=¥ Device Repository x

Location Usar v Edit Locations.. .
(C: ProgramData'EcoSruure Machine Expert'V2.0'YUser Devices)

Installed Device Descriptions

:"r ing for a full text search Vendor  Schreider Blectric s Instal...
Name Vendor Vi Uninstad
+ ([ ™7 Analog 1/ Blocks Bxoort..

+ [{ ™7 Digital 1/0 Blocks

+ - [ ™7 Feld Bus Interface 1jO Blodks It DTM..,
*. [ 17 Power Distribution Blocks v
< > Renew Device
: Repository
= @ C:\Userspanyao. I'Desktop B BFI04\3. BRE I SRR B U LF S EI (EtherNetlP..,
@ Device "EI2-HHOO-C INN" instalied to device repository
Details...

Figure 5-7-11Install EDSdocument
5. New project and equipment configuration

Open Machine Expert V2.0, create a project, and right-click "EtherNET_1"Select "Add
Device", as shown in Figure 5-7-12As shown,

In the Add Device window, select "Protocol Manager" > "Industrial Ethernet Manager”,
as shown in Figure 5-7-13As shown, right-click "_" under the device tree(Industrial Ethernet
Manager)">"Add Device", in the device window, select "DECOWELL AUTOMATION
CO.,LTD", and select "EI2-HHO0-C1NN", as shown in Figure 5-7-14shown.

LM Counter= = mbnns Ll

k
L puse g @ 4t I
[ cartride = Copy Address
@ 10 Bus, 4 Paste ol

|ﬂ COM Bi ¥ Delete
& ctherne [ Properties...

= Serial_L .
- m = Add Object
(i mag
ekl =l Add Folder... fere
= eri
M I Add Device... fue
ﬂ Mot
Disable Dewce ;’
Update Device... bor protocol
v Convert Device...
Transfer device settings
10 Summary..

Power consumption...

Figure 5-7-12Add a device
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Name Vendor Version Description
= Efi Protocol Managers
3 industrial Ethernet Manager | Scheider Electric 10,1235 This service allows to manage the I
+ 1) Fieldbuses
<

Figure 5-7-13Adding Industrial Ethernet Manager

String for a full text search | Vendor DECOWELL AUTOMATION CO. LD,
Name Vendor Version

e E12-0S00-NINN DECOWELL AUTOMATION CO,,LTD. Major Revision=16%1, Minor Revisio
%> EI2-8800-CONN DECOWELL AUTOMATION CO, LTD. Major Revision=16#1, Minor Revisio
% EI2-8800-C1NN DECOWELL AUTOMATION CO.,LTD. Major Revision=16%1, Minor Revisio
% EI12-8800-C2NN DECOWELL AUTOMATION CO, LTD, Major Revision=16%1, Minor Revisio
% E12-HHO0-CONN DECOWELL AUTOMATION CO.,LTD. Major Revision=16=1, Minor Revisio
t.'-|Eﬂ+rm-cm DECOWELL AUTOMATION CO. LTD. Major Revision=16#1, Minor Revisio
% E12-5000-CNNN DECOWELL AUTOMATION CO.,LTD. Major Revision=16%1, Minor Revisio
I rB-1120 DECOWELL AUTOMATION CO, LTD, Major Revision=16%1, Minor Revisio ¥

< >

[A i Rosmtanie [ Mo el s M e ol [ 1 Pl sndatad it

Figure 5-7-14Add EI2-HHOO-C1NN
Configure the parameters of EI2-HHO0-C1NN by double-clicking “EI12-HHOO-C1NN” in the

device tree. Set the IP address to a static IP address, as shown in Figure 5-7-15.

| Deviees tree ~ 3 X U EIZ_HHOO_CANN X
Select Al ¥ | Targetsettngs Connections LUser Parameters ¥= Etherhet/IP [/OM
l < :i Address Settings [DHCP server confiauration)
Wl by O 1P Address by DHCP [pevice 1 ]
= W MyController (TM241CE24T/U) - ;
8. 50 i oty () IP Address by BOOTP
& 00 (Digital Cutputs) @ Fixad IP Address
" Counters (Counters)
Li Pulse_Generators {Pulse Generators) Electronic Keying
# Cartridge_1 (Cartridge) [7] Check Device Type [12
£ 10 Bus (10bus - TM3) 1 Chetk Vesidoe G =
@ com_Bus (coM bus)
- [8 Ethemet_1 Ethernet Network) M Seasreatend

= ial & 3 i [ eheck Major Revision
% EI2_HHOO_CINN (E12-HHO0-C INN) _]
= 4§ Serd_Line_1 (Serial ine)

[] Check Minor Revision

[ Machine_Expert_Network_Manager (Mag| | ReStore default values
= & Serial Line_2 (Serial line)
ﬂwmmﬁMmmmw] Protocol on the fieldbus
EthametP

Protocol used by the device

Figure 5-7-15Configuration IPaddress

To view the I/O address mapping, double-click “EI2-HHO0-C1NN” in the device tree and
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navigate to the EtherNet/IP I/O Mapping section, as shown in Figure 5-7-16.

% EI2_HHOO_CINN X

Target settings Connections User Parameters EtherNet/IP I/O Mapping | #=%= EtherNet/IP IEC Objects Status () Information
Find Filter Show all v =k Add FB for IO Channel...
Variable Mapping Channel Address Type Default Value Unit  Description
= |1l Exdusive Owner
L iwEI2_HHOO0_CINN... (] Input Exdusive Owner %IW7 WORD
" qwEl2_HHDO_C1N... L] Output Exdusive Owner %QW2 WORD

Figure 5-7-16 I0Address Mapping
5.7.3 CODESYS and EtherNet/IP Protocol IOModule connections and configuration
1. Communication connection diagram, as shown in Figure 5-7-8Shown

PC

P
12l Codesys SP16

Emﬂem‘;s)

EI2-HHOO-C1NN

Figure 5-7-17Communication connection diagram
2. Hardware configuration as shown in Table 5-7-3Shown

Table 5-7-3Hardware Configuration Table

hardware quantity Remark
Programming Computer 1 CodesysSP16,IP Setting Toolsoftware
PLC 1
El2-HHOO0-C1NN 1 EtherNet/IP Protocol 16DI/16DOModules
Communication line several

Module IP Address Settings
Open IP Setting Tool software, select the network card connected to the module, and

scan the online 10 Module, as shown in Figure 5-7-18shown.
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= O

cation(C) Setup(S) language{l} Help(H)

Next power on  [ep—
Startvith ixed P [ @ 1o aaca.

| ag ScanEmeriene |
ln devices(A)...

[ Display detailed information(D) ‘

Figure 5-7-18Scan Online IOModules

Select the module in the scan list whose IP address needs to be modified (Note: the
module is set to BOOTP by default at the factory and has no IP address. After setting the IP

address, be sure to select "Static IP" as the startup mode), as shown in Figure 5-7-19shown.

file(Fl Communication(C) Setup(S) Language(l) Help(H)

Scan EtherhletiP
ey

Setup IP addr,

Please set the IP address

FRA4FE0013

MAC addr

Device name EI2 HHOO CONN(EtherNeli®)

IP addr (required)(l 91 . 158 . O v 3L

[ Display detail a0 | [ 1 |
Hostname (optionalfH) | ‘
IP addr. setiing at i
next power on(ly) I Satwihfeed . (v

Search available IP addresses(F)... l OK l Cancel

Figure 5-7-19Setting IP address

Recommendation: The module does not have an IP address by default. Before configuring the
module's IP address, first set the PC’s network adapter IPv4 to the same subnet as the IP address
you intend to assign to the module.
4. Install EDS document

Open the CODESYS SP16 programming software, go to the menu bar and select
“Tools” > “Device Repository.” In the Device Repository window, click “Install” as shown in
Figure 5-7-20. Then, select “General Version” > “EI2-HHO0-C1NN” from the EDS folder and

confirm the installation.
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2 Device Repository Ee

Location  System Repository ~ Edit Locations...
(C:\ProgramData\CODESYS\Devices)

Installed Device Descriptions

:-_'-uu:u_: for a ful text search vendor | <All vendors> - Instail...

Name Vendor Version Description

+ (i miscelaneous
* I'_!_’I Feldbuses

t Q HMI devices
£ ([ mcs

+ @ sofiMation drives

Figure 5-7-20 Install EDS document
5. New project and equipment configuration
Open CODESYS SP16, create a new project, and right-click on “Device” in the device tree,
then select “Add Device.” In the Add Device window, select “Ethernet,” as shown in Figure
5-7-21.
Next, right-click on “Ethernet” in the device tree and select “Add Device.” In the Add Device

window, choose “EtherNet/IP Scanner,” as shown in Figure 5-7-22.

= 3 inidedd
3 Owioe [CODESYS SeftMotian Win V3 w64

Figure 5-7-21 Adding an Ethernet Adapter

Name Vendor Version Description
= 1 Fedbuses
= = EtherNet/IP
+ = EtherNet/IP Local Adapter
= == EtherMet/IP Scanner
[ [Ethertet/P Scanner | 35 - Smart Software Solutions b~ 4.4.1.0  EtherNet/IP Scaner
+ {3 HomeBBuilding Automation
+ 8 Modbus
+- ¥ PROFINET IO

Figure 5-7-22 Add Ethernet IP scanner

Configure the network card of the Ethernet adapter, double-click "Ethernet" under the
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device tree, open the page and select the network card that needs to communicate with the

EtherNet/IP slave, as shown in Figure 5-7-23 shown.

= [ intted =)
« i) Dk emrchnd] {COOESE Combrol Wi VEesd) | | O Metwoeklnbartore: [
= B Aciose Sharnet Device Y Mapaing ¥ address 97 .08 . 0 . 1
= £} Apphcation
D Loy Merager Ethernet Device TEC Ohiects Sibostm i L
E] Puc_Re pRE)
= 8 Task Confiarabon i

= £ SuPscanneI0Tas (TEC Tasks) g
] Ethertiet_F 50 I

= 25 SaPScae ServiorTask (TEC-Tacks) || | Tnformation
] Ethertiet 1P Scamner ServceCyc

= g8 MarTask [IEC Tasks)
3 s cuc

JOCyde

0

1] Exnertiat P_carver Ehertiet 1P Scanner)
" SofiMation General dus Pod (Safioton General |

Defwilt eatovy | O O . 0 @

[ TTo: PRI 580 8800522

Measaces - Total & serarfal. 0 sesrinats]. 2 messacelsl

Figure 5-7-23 Configuring the Ethernet Adapter Network Card
Right-click the "EtherNet IP_Scanner"Select "Add Device", select "EI2-HHOO-C1NN",

as shown in Figure 5-7-24 shown.

= ) Application Action
m Library Manager Etheriet (@) Append device () Insert devica : : (O Update device
\E] PLC_PRG (PRG) I
= 3 Task Confiuration I Etherlet] [E-u‘:'\g for a full text search Vendor | <All vendars>
= & BNIPScannerI0Task (IEC-Tasks) Status Name Vendor
& EtherNet_1P_Scanner,I0Cyde | | = [ Feidbuses
= €8 ENPScannerServiceTask (IEC-Tasks) || | Informat - Etheret
&] EtherMet_IP_Scanner. ServiceCyc | | =
= & ManTask (EC-Tasks) s [Er2-HHO0-C 1NN | AUTOMATION €
B8] PLC_PRG c S El ~Smart Software Solution
[ Ethernet (Ethernet) H svam DECOWELL AUTOMATION C
i EtherNet_IP_Scanrer (E Scarner) (@ everon DECOWELL AUTOMATION C
% SoftMotion General Axis Pool (SoftMof eneral :‘3 EX-1120 DECOWELL AUTOMATION C
{ Generic EtherNet/IP device 35 - Smart Software Solutior
Fiisa DECOWELL AUTOMATION C
B wre_1on FECAWE | ALTOMATTOR ©

Figure 5-7-24 Add EI2-HHO0-C1NNModules
Configure the IP address of the EI2-HHO0-C1NN adapter by double-clicking
“EI2-HHOO-C1NN” in the device tree. Enter the IP address (make sure it matches the actual

IP address set on the module), as shown in Figure 5-7-25.
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=G thtiteds -
= - Genaral
= [ Device (CODESYS Contral Win V3 x64) Address Settings
= & PLCLagk: Connections Paddress | 192 . 168 . 1 . 65
= I} Application Ethel'
w Library Manager Assemblies
2] PLC_PRG {PRG) "
= 5 Task Configuration User-Defined Parametars Elactronic Keying
= @& ENPScannerlOTask (IEC-Tasks) Leg [[] compatibility check
@] EtherNet_IP_Scanner,10Cyde :
Vendor L B ch atch
-, @ ENIPScannerServiceTask ([EC-Tasks) EtherNet/IP /O Mapping Vendor I I-1-157 || Check mate
&) Ethertiet_IP_Scanner, ServiceCyd Devicetype |12 | [ check match
= i EtherNet/IP IEC Objects
& MaTask (IEC-Tasks) Productcode 65035 B Chedk match
&3] pLC_PRG i =
- Salus Majorrevision |1 [ Check match
= (@ Ethernet [Ethernet) - :
= Ijj EtherNet IP_Scanner (EtherNet/IP Scanner) Information Minor revision 1 [] Chack match
| » EI2_HHOO0_C INN (E12-HH00-C INN)
d SofiMotion General Axis Pool (SeftMotion General |

Figure 5-7-25Configuration EI2-HHO0-C1NNModule IPaddress

To view the I/O address mapping, double-click “EI2-HHO0-C1NN” in the device tree and

go to the EtherNet/IP 1/0 Mapping section, as shown in Figure 5-7-26.

fices. = 3 X || [[] EtherNet P Scanner | G them=t | [ Dewice . EIZ_HHOO_CINN X
1 Lnotedd e
L e Find Filter Show all
= Device (CODESYS Contral Win V3 x64) : —e——— - —
=@ bl i hannel r T Jrii ipti
Bl pLcLoge Cantecing Variable Mapping Channel Address ype Unit  Description
= 3 Application = [ Exclusve Dwner
= (i Ethemet Ethernet) Assemblies & % Trput Deta W0 WORD
= [{ EtherNet_TP_Scanner (EtherNet/IP Scaner) || | “ e OutputData | %QWD WORD
S 'EIi_H"iD:C_lNN {E[Z'I'HW-C Ml = Uger-Defined Parameaters

% SoftMotion General Axis Pool (SoftMotion General

EtherNet/IP 1j0 Mapping

EtherNet/iP TEC Objects
Status

Infarmation

Figure 5-7-26View |0 Address Mapping

5.7.4 Sysmac Studio and EtherNet/IP Protocol 10 Module connections
configuration

1. Communication connection diagram, as shown in Figure 5-7-27Shown

PC

Sysmac Studio

NX1P2

> 1

EI2-HHOO-CINN

Figure 5-7-27Communication connection diagram

2. Hardware configuration as shown in Table 5-7-4Shown
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Table 5-7-4Hardware Configuration Table

hardware quantity Remark
Sysmac Studio,IP

Programming Computer 1
Setting Toolsoftware

NX1P2 1
EtherNet/IP Protocol

EI2-HHOO-C1NN 1
16DI/16DOModules

Communication line several

Module IPAddress Settings
Open IP Setting Tool software, select the network card connected to the module, and
scan the online IO Module, as shown in Figure 5-7-28shown.
Em

State MAC addr Device name
h FEAAFB.00:13B2 |EI2-HHOO-CONN(EiherNetiP| 182.188.0.11

Next power on

w3y Setup
Startwith fired 1P |IEAETFTEIN

g6 Scan Emeneup
devices(d)...

1 Display detailed information(D) Exit(X)

Figure 5-7-28Scan Online IO Modules
Select the module in the scan list whose IP address needs to be modified (Note: the
module is set to BOOTP by default at the factory and has no IP address. After setting the IP
address, be sure to select "Static IP" as the startup mode), as shown in Figure 5-7-29

shown.
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Setup(S) Language(l) Help™)

Device name IP addr Next power on my Setup
EI2-HHOO-CONN(EInerNelIP|| 192.168.0.11 | Start with fixed IP @ 1P addr (). \

M Scan EtheretiP
devices(4)

Setup IP addr.

Please set the IP address.

MAC addr FBA4FEOD13B2
Device name El2-HHOO-CONN(EtherNetiP)
< >
1P addr (required) 92 , 168 . 0 ., 11 |
Display detal W | l Exit(x)

Host name (optionalH)

IP addr. seting at
next power on (i)

Search available IP addresses(El..

Siart with fixed (P

Figure 5-7-29Setting IPaddress
Recommendation: The module does not have an IP address by default. Before configuring the
module's IP address, first set the PC’s network adapter IPv4 to the same subnet as the IP address
you intend to assign to the module.
4. New project and equipment configuration
Open the Sysmac Studio programming software to create a project, and configure the EtherNet/IP
port with a fixed IP address (matching the actual PLC port IP), as shown in Figure 5-7-30.

Multiview Explorer

| new_Controller 0 |

therCAT v IP Address
» = CPU/Expansion Racks ; D) Fixad setfing
& |/OMap 1P addrass [ERePE [F: 0 N 39[_
¥ = Controller Setup Subnet mask |ERREeL T LI

Default gateway |

|
P Obtain from BOOTP server.
@ Fixat the |P address obtained from BOOTP server.
¥ Operation at IP Address Duplication
Use of duplicated IP address  Stop @ Do notstop

¥ DNS

DNS Q Do notise @ Use

; JA Settings = Priority DNS server
¥ & POUs Domain name ([

¥ Host Name - IP Address

¥ | Program0

H Name

Figure 5-7-30 EtherNet/IP Port Settings
Create all variables, create input and output variables in the global variables, and the

length of the variables must be consistent with the actual
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The input and output byte lengths in the module are consistent, as shown in the figure

5-7-31 shown.

ultiview Explorer i

| : T %
new Controller 0 v || Group Filter 'Y (No group) v
Initial Walus l AT l Hetain | Constant | Metwnrk Pubjish

Mame | Nata Tyna |
i e +

Sl nput ARRAV[C..1] OF byte | ' @ o |
Sl Output ARRAY[(..1] OF byte | O e

Configurations and Setup
Pla_g_samming
¥ @ POUs

l
g
E
i

Figure 5-7-31Creating Global Variables
In the menu bar, select “Tools” > “EtherNet/IP Connection Settings”. In the EtherNet/IP
List window, double-click the node address to open the EtherNet/IP Port Connection

Settings window, as shown in Figure 5-7-32.

p Device Information
¥ Tag Sets

Tag Sets/Max: 0 / 32 Tags/Max: 0 / 256

Figure 5-7-32 Open the built-in EtherNet/IP port setting connection setting window
Register variables. In the built-in EtherNet/IP port setting connection setting window,
select the "Tag Group" window and click "Register All" to register the newly created global

variables, as shown in Figure 5-7-33 shown.

85



FS Series Remote 10 User Manual HNELITYELL

« Toolbox

| Target Device
110716

Device Information
Tag Sets/Max: 0/ 32 Tags/Max: 0O [ 256 Reqistrabion All

Output
—

B Tag set Registration Setting

Sl B i Uala-typcs
E winput Tag

[ Input ARRAY[D.1] OF byte
K 'w output Tag

& Output ARRAY[0..1] OF byte

Check Selected ltems | | Uncheck Selected ltems

Figure 5-7-33Global variable registration
To install the EDS file, in the opened Built-in EtherNet/IP Port Connection Settings window,
right-click on the blank area of the toolbox on the right and select “Show EDS Library”, as
shown in Figure 5-7-34. In the EDS Library window, select “Install” and open the EDS file to

be installed, as shown in Figure 5-7-35.

» Device Information

ts/Max: 0 / 32 Tags/Max: 0 [ 256  Registration Al Import

Qutput
Tag Set Name | BitSelection | Size (Byie) | Size (Bit) Display EDS Library
4

Return All to Default -
Variable ivanie | Siee poyic

Figure 5-7-34 Display EDS Library

B EDS Library — O X

-}
B OMRON Corporation
B Omron Adept Technologies, Inc.
B Omron Microscan Systems, Inc.
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Figure 5-7-35Install EDS document
Add the device to be communicated with and configure its parameters. In the toolbox,
select “Add Target Device”, as shown in Figure 5-7-36. The user needs to enter the
EtherNet/IP slave IP address, slave model, and revision version. After completion, click the

“Add” button at the lower left of the dialog box.

Target Device

MNode address
Model name
Revision

Figure 5-7-36Add target device

In the toolbox, set the target device "192.168.1.65 EI2-HHO0-C1NNVersion 1" and drag
it to the connection, as shown in Figure 5-7-37As shown,

Configure the target device parameters,EI2-HHOO-C1NNEnter the target variable as 100,
the output target variable is 101, the input and output byte sizes are both 10, select the
registered global variable as the starting variable, as shown in Figure 5-7-38As shown;

Switch the PLC to online mode and then to program mode, then select “Transfer to

Controller”, as shown in Figure 5-7-39.

168165 EI2-8800-CONN Revi

Figure 5-7-37Adding a connected device
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Connection
Connections/Max 2 / 32

Figure 5-7-38Configure target device parameters

= I [2
(5] L

Target Variable | Size [Byte] |Originator Variable | Siz

+ 0

Device Bandwidth Display EDS Library

Retumn All to Default

Figure 5-7-39EtherNet/IP Configuration transfer to controller
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Appendix

FS Series product ordering information

FS integrated-PROFINET communication protocol digital input and output module

Product Model Product Description Order Number

PROFINET 8-channel digital input (NPN & PNP)
PN-8800-CONN 00-01-01
8-channel digital output (NPN)

PROFINET 8-channel digital input (NPN & PNP)
PN-8800-C1NN 00-01-02
8-channel digital output (PNP)

PROFINET 8-channel digital input (NPN & PNP)
PN-8800-C2NN 00-01-03
8-channel digital output (relay)

PROFINET 16-channel digital input (NPN & PNP)
PN-HHOO0-CONN 00-01-04
16-channel digital output (NPN)

PROFINET 16-channel digital input (NPN & PNP)
PN-HHOO0-C1NN 00-01-05
16-channel digital output (PNP)

PN-S000-CNNN PROFINET 32-channel digital input (NPN & PNP) 00-01-08
PN-0S00-NONN PROFINET 32 digital outputs (NPN) 00-01-09
PN-0SO00-N1NN PROFINET 32 digital outputs (PNP) 00-01-10

FS integrated-EtherCAT communication protocol digital input and output module

Product Model Product Description Order Number

EtherCAT 8-channel digital input (NPN & PNP) 8-channel
EC-8800-CONN 00-02-01
digital output (NPN)

EtherCAT 8-channel digital input (NPN & PNP) 8-channel
EC-8800-C1NN 00-02-02
digital output (PNP)

EtherCAT 8-channel digital input (NPN & PNP) 8-channel
EC-8800-C2NN 00-02-03
digital output (relay)

EtherCAT 16-channel digital input (NPN & PNP)
EC-HHOO0-CONN 00-02-04
16-channel digital output (NPN)
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EtherCAT 16-channel digital input (NPN & PNP)

EC-HHO00-C1NN 00-02-05
16-channel digital output (PNP)

EC-S000-CNNN EtherCAT 32-channel digital input (NPN & PNP) 00-02-08

EC-0S00-NONN EtherCAT 32-channel digital output (NPN) 00-02-09

EC-0S00-N1NN EtherCAT 32-channel digital output (PNP) 00-02-10

FS integrated-CC-Link communication protocol digital input and output module

Product Model

Product Description

CC-LINK 8-way digital input (NPN & PNP) 8-way digital

Order Number

CL-8800-CONN 00-03-01
output (NPN)
CC-LINK 8-way digital input (NPN & PNP) 8-way digital
CL-8800-C1NN 00-03-02
output (PNP)
CC-LINK 8-way digital input (NPN & PNP) 8-way digital
CL-8800-C2NN 00-03-03
output (relay)
CC-LINK 16-channel digital input (NPN & PNP)
CL-HHO0-CONN 00-03-04
16-channel digital output (NPN)
CC-LINK 16-channel digital input (NPN & PNP)
CL-HHO0-C1NN 00-03-05
16-channel digital output (PNP)
CL-SO000-CNNN CC-LINK 32-channel digital input (NPN & PNP) 00-03-07
CL-0S00-NONN CC-LINK 32-channel digital output (NPN) 00-03-08
CL-0S00-N1NN CC-LINK 32-channel digital output (PNP) 00-03-09

FS integrated-DeviceNet communication protocol digital input and output module

Product Model

Product Description

Order Number

DEVICENET 8-channel digital input (NPN & PNP)

DN-8800-CONN 00-04-01
8-channel digital output (NPN)
DEVICENET 8-channel digital input (NPN & PNP)
DN-8800-C1NN 00-04-02
8-channel digital output (PNP)
DEVICENET 8-channel digital input (NPN & PNP)
DN-8800-C2NN 00-04-03

8-channel digital output (relay)
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DEVICENET 16-channel digital input (NPN & PNP)
DN-HHOO0-CONN 00-04-04
16-channel digital output (NPN)

DEVICENET 16-channel digital input (NPN & PNP)
DN-HHOO-C1NN 00-04-05
16-channel digital output (PNP)

DN-S000-CNNN DEVICENET 32-channel digital input (NPN & PNP) 00-04-08
DN-0S00-NONN DEVICENET 32-channel digital output (NPN) 00-04-09
DN-0S00-N1NN DEVICENET 32-channel digital output (PNP) 00-04-10

FS integrated- CC-Link IE Field Basic communication protocol digital input and output module

Product Model Product Description Order Number

CC-Link IE Field Basic 8-channel digital input (NPN &
Cl-8800-CONN 00-06-01
PNP) 8-channel digital output (NPN)

CC-Link IE Field Basic 8-channel digital input (NPN &
CI-8800-C1NN 00-06-02
PNP) 8-channel digital output (PNP)

CC-Link IE Field Basic 8-channel digital input (NPN &
CI-8800-C2NN 00-06-03
PNP) 8-channel digital output (relay)

CC-Link IE Field Basic 16-channel digital input (NPN &
CI-HHOO0-CONN 00-06-04
PNP) 16-channel digital output (NPN)

CC-Link IE Field Basic 16-channel digital input (NPN &
CI-HHOO0-C1NN 00-06-05
PNP) 16-channel digital output (PNP)

CC-Link IE Field Basic 32-channel digital input (NPN &

CI-S000-CNNN 00-06-06
PNP)

CI-0S00-NONN CC-Link IE Field Basic 32-channel digital output (NPN) 00-06-07

CI-0S00-N1NN CC-Link IE Field Basic 32-channel digital output (PNP) 00-06-08

FS integrated-PROFINET communication protocol digital input and output module

Product Model Product Description Order Number

PROFINET 8-channel digital input (NPN & PNP)
PN2-8800-CONN 00-01-11
8-channel digital output (NPN)
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PROFINET 8-channel digital input (NPN & PNP)

PN2-8800-C1NN 00-01-12
8-channel digital output (PNP)
PROFINET 8-channel digital input (NPN & PNP)
PN2-8800-C2NN 00-01-13
8-channel digital output (relay)
PROFINET 16-channel digital input (NPN & PNP)
PN2-HHOO0-CONN 00-01-14
16-channel digital output (NPN)
PROFINET 16-channel digital input (NPN & PNP)
PN2-HHOO0-C1NN 00-01-15
16-channel digital output (PNP)
PN2-S000-CNNN PROFINET 32-channel digital input (NPN & PNP) 00-01-18
PN2-0S00-NONN PROFINET 32 digital outputs (NPN) 00-01-19
PN2-0S00-N1NN PROFINET 32 digital outputs (PNP) 00-01-20

FS integrated-EtherNet/IP communication protocol digital input and output module

Product Model

Product Description

EtherNet/IP 8-channel digital input (NPN & PNP)

Order Number

EI2-8800-CONN 00-05-11
8-channel digital output (NPN)
EtherNet/IP 8-channel digital input (NPN & PNP)
EI2-8800-C1NN 00-05-12
8-channel digital output (PNP)
EtherNet/IP 8-channel digital input (NPN & PNP)
EI2-8800-C2NN 00-05-13
8-channel digital output (relay)
EtherNet/IP 16-channel digital input (NPN & PNP)
EI2-HHOO-CONN 00-05-14
16-channel digital output (NPN)
EtherNet/IP 16-channel digital input (NPN & PNP)
EI2-HHOO-C1NN 00-05-15
16-channel digital output (PNP)
EI2-S000-CNNN EtherNet/IP 32 digital inputs (NPN & PNP) 00-05-16
EI2-0S00-NONN EtherNet/IP 32 digital outputs (NPN) 00-05-17
EI2-0S00-N1NN EtherNet/IP 32 digital outputs (PNP) 00-05-18
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